Skip to content

← Actionable
High, CVSS 7.2amended

Cross-Site Scripting in Wagtail

CVE-2020-15118GHSA-2473-9hgq-j7xw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 2.9.3, 2.7.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI wagtail

    Affected
    < 2.7.4>= 2.8rc1, < 2.9.3
    Fixed in
    2.9.3, 2.7.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-15118: 1.10% estimated exploitation activity in the next 30 days; percentile 65.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When a form page type is made available to Wagtail editors through the wagtail.contrib.forms app, and the page template is built using Django's standard form rendering helpers such as form.asp (as directed in the documentation), any HTML tags used within a form field's help text will be rendered unescaped in the page. Allowing HTML within help text is an intentional design decision by Django; however, as a matter of policy Wagtail does not allow editors to insert arbitrary HTML by default, as this could potentially be used to carry out cross-site scripting attacks, including privilege escalation. This functionality should therefore not have been made available to editor-level users. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patches Patched versions have been released as Wagtail 2.7.4 (for the LTS 2.7 branch) and Wagtail 2.9.3 (for the current 2.9 branch). In these versions, help text will be escaped to prevent the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2473-9hgq-j7xw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2473-9hgq-j7xw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15118

Advisory: Cross-Site Scripting in Wagtail
IDs: CVE-2020-15118, GHSA-2473-9hgq-j7xw
Record: https://patchnext.com/advisories/cve-2020-15118 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wagtail 2.9.3, 2.7.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI wagtail: affected < 2.7.4; >= 2.8rc1, < 2.9.3; fixed in 2.9.3, 2.7.4

## Suggested inspection (read-only)
- `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wagtail.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2473-9hgq-j7xw (OSV record GHSA-2473-9hgq-j7xw lists affected ranges: PyPI wagtail >=2.8rc1 =0 <2.7.4 (fixed))
- Verified: https://github.com/advisories/GHSA-2473-9hgq-j7xw (GitHub-reviewed advisory GHSA-2473-9hgq-j7xw lists affected ranges: PyPI wagtail >=0 =2.8rc1 <2.9.3)

Commands are suggestions: review each one before running it.

Loading voting…