Skip to content

← Actionable
High, CVSS 7.7

Etcd Gateway can include itself as an endpoint resulting in resource exhaustion

CVE-2020-15114GHSA-2xhq-gv6c-p224

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (go.etcd.io/etcd 3.4.10, 3.3.23), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go go.etcd.io/etcd

    Affected
    >= 3.4.0-rc.0, <= 3.4.9< 3.3.23
    Fixed in
    3.3.23, 3.4.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H
EPSS
  • CVE-2020-15114: 1.13% estimated exploitation activity in the next 30 days; percentile 66.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability type Denial of Service Detail The etcd gateway is a simple TCP proxy to allow for basic service discovery and access. However, it is possible to include the gateway address as an endpoint. This results in a denial of service, since the endpoint can become stuck in a loop of requesting itself until there are no more available file descriptors to accept connections on the gateway. References Find out more on this vulnerability in the security audit report For more information If you have any questions or comments about this advisory: Contact the etcd security committee

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2xhq-gv6c-p224

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15114

Advisory: Etcd Gateway can include itself as an endpoint resulting in resource exhaustion
IDs: CVE-2020-15114, GHSA-2xhq-gv6c-p224
Record: https://patchnext.com/advisories/cve-2020-15114 (revision 1, source checked 26 Oct 2026, 15:03 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: go.etcd.io/etcd 3.4.10, 3.3.23. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go go.etcd.io/etcd: affected >= 3.4.0-rc.0, <= 3.4.9; < 3.3.23; fixed in 3.3.23, 3.4.10

## Suggested inspection (read-only)
- Go go.etcd.io/etcd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on go.etcd.io/etcd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2xhq-gv6c-p224 (GitHub-reviewed advisory GHSA-2xhq-gv6c-p224 lists affected ranges: Go go.etcd.io/etcd >=3.4.0-rc.0 =0 <3.3.23)

Commands are suggestions: review each one before running it.

Loading voting…