Skip to content

← Actionable
High, CVSS 8.8

Missing Required Cryptographic Step Leading to Sensitive Information Disclosure in TYPO3 CMS

CVE-2020-15098GHSA-m5vr-3m74-jwxp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-core 10.4.6, 9.5.20; typo3/cms 10.4.6, 9.5.20), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist typo3/cms-core

    Affected
    >= 9.0.0, < 9.5.20>= 10.0.0, < 10.4.6
    Fixed in
    9.5.20, 10.4.6
  • Packagist typo3/cms

    Affected
    >= 10.0.0, < 10.4.6>= 9.0.0, < 9.5.20
    Fixed in
    9.5.20, 10.4.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-15098: 2.23% estimated exploitation activity in the next 30 days; percentile 82.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Meta CVSS: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C (8.2) CWE-325, CWE-20, CWE-200, CWE-502 Problem It has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. This allows to inject arbitrary data having a valid cryptographic message authentication code (HMAC-SHA1) and can lead to various attack chains as described below. TYPO3-CORE-SA-2020-007, CVE-2020-15099: Potential Privilege Escalation + the database server used for a TYPO3 installation must be accessible for an attacker (either via internet or shared hosting network) + CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C (7.5, high) TYPO3-CORE-SA-2016-013, CVE-2016-5091: Insecure Deserialization & Remote Code Execution + an attacker must have access to at least one Extbase plugin or module action in a TYPO3 installation + CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C (9.1, critical) The overall severity of this vulnerability is high (8.2)…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m5vr-3m74-jwxp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15098

Advisory: Missing Required Cryptographic Step Leading to Sensitive Information Disclosure in TYPO3 CMS
IDs: CVE-2020-15098, GHSA-m5vr-3m74-jwxp
Record: https://patchnext.com/advisories/cve-2020-15098 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typo3/cms-core 10.4.6, 9.5.20; typo3/cms 10.4.6, 9.5.20. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist typo3/cms-core: affected >= 9.0.0, < 9.5.20; >= 10.0.0, < 10.4.6; fixed in 9.5.20, 10.4.6
- Packagist typo3/cms: affected >= 10.0.0, < 10.4.6; >= 9.0.0, < 9.5.20; fixed in 9.5.20, 10.4.6

## Suggested inspection (read-only)
- Packagist typo3/cms-core: check the installed version with your package manager.
- Packagist typo3/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typo3/cms-core, typo3/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m5vr-3m74-jwxp (GitHub-reviewed advisory GHSA-m5vr-3m74-jwxp lists affected ranges: Packagist typo3/cms-core >=9.0.0 =10.0.0 =10.0.0 =9.0.0 <9.5.20)

Commands are suggestions: review each one before running it.

Loading voting…