Skip to content

← Actionable
Unrated

img_auth.php may leak private extension images into the public cache

CVE-2020-15005GHSA-xpv7-93cm-4mxv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mediawiki/core 1.34.2, 1.33.4, 1.31.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mediawiki/core

    Affected
    < 1.31.8>= 1.32.0, < 1.33.4>= 1.34.0, < 1.34.2
    Fixed in
    1.34.2, 1.33.4, 1.31.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2020-15005: 1.30% estimated exploitation activity in the next 30 days; percentile 70.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In MediaWiki before 1.31.8, 1.32.x and 1.33.x before 1.33.4, and 1.34.x before 1.34.2, private wikis behind a caching server using the imgauth.php image authorization security feature may have had their files cached publicly, so any unauthorized user could view them. This occurs because Cache-Control and Vary headers were mishandled.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xpv7-93cm-4mxv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-15005

Advisory: img_auth.php may leak private extension images into the public cache
IDs: CVE-2020-15005, GHSA-xpv7-93cm-4mxv
Record: https://patchnext.com/advisories/cve-2020-15005 (revision 1, source checked 26 Oct 2026, 14:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mediawiki/core 1.34.2, 1.33.4, 1.31.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mediawiki/core: affected < 1.31.8; >= 1.32.0, < 1.33.4; >= 1.34.0, < 1.34.2; fixed in 1.34.2, 1.33.4, 1.31.8

## Suggested inspection (read-only)
- Packagist mediawiki/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mediawiki/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xpv7-93cm-4mxv (GitHub-reviewed advisory GHSA-xpv7-93cm-4mxv lists affected ranges: Packagist mediawiki/core >=0 =1.32.0 =1.34.0 <1.34.2)

Commands are suggestions: review each one before running it.

Loading voting…