RSA-PSS signature validation vulnerability by prepending zeros in jsrsasign
CVE-2020-14968GHSA-q3gh-5r98-j4h3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jsrsasign 8.0.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm jsrsasign
- Affected
- >= 3.0.0, < 8.0.17
- Fixed in
- 8.0.17
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q3gh-5r98-j4h3 lists affected ranges: npm jsrsasign >=3.0.0 <8.0.17 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-14968: 2.86% estimated exploitation activity in the next 30 days; percentile 86.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Jsrsasign can verify RSA-PSS signature which value can expressed as BigInteger. When there is a valid RSA-PSS signature value, this vulnerability is also accept value with prepending zeros as a valid signature. - If you are not use RSA-PSS signature validation, this vulnerability is not affected. - Risk to accept a forged or crafted message to be signed is low. - Risk to raise memory corruption is low since jsrsasign uses BigInteger class.
Patches Users using RSA-PSS signature validation should upgrade to 8.0.17.
Workarounds Reject RSA-PSS signatures with unnecessary prepending zeros.
References https://github.com/kjur/jsrsasign/security/advisories/GHSA-q3gh-5r98-j4h3 https://github.com/kjur/jsrsasign/issues/438 https://nvd.nist.gov/vuln/detail/CVE-2020-14968 https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14968 https://vuldb.com/?id.157125…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record GHSA-q3gh-5r98-j4h3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-14968 Advisory: RSA-PSS signature validation vulnerability by prepending zeros in jsrsasign IDs: CVE-2020-14968, GHSA-q3gh-5r98-j4h3 Record: https://patchnext.com/advisories/cve-2020-14968 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jsrsasign 8.0.17. A vendor fix does not mean a deployment is fixed. ## Affected components - npm jsrsasign: affected >= 3.0.0, < 8.0.17; fixed in 8.0.17 ## Suggested inspection (read-only) - `npm ls jsrsasign --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jsrsasign. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q3gh-5r98-j4h3 (OSV record GHSA-q3gh-5r98-j4h3 lists affected ranges: npm jsrsasign >=3.0.0 <8.0.17 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…