RSA PKCS#1 decryption vulnerability with prepending zeros in jsrsasign
CVE-2020-14967GHSA-xxxq-chmp-67g4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jsrsasign 8.0.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm jsrsasign
- Affected
- < 8.0.18
- Fixed in
- 8.0.18
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xxxq-chmp-67g4 lists affected ranges: npm jsrsasign >=0 <8.0.18 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xxxq-chmp-67g4 lists affected ranges: npm jsrsasign >=0 <8.0.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-14967: 2.27% estimated exploitation activity in the next 30 days; percentile 83.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Jsrsasign supports RSA PKCS#1 v1.5 (i.e. RSAES-PKCS1-v15) and RSA-OAEP encryption and decryption. Its encrypted message is represented as BigInteger. When there is a valid encrypted message, a crafted message with prepending zeros can be decrypted by this vulnerability. - If you don't use RSA PKCS1-v15 or RSA-OAEP decryption, this vulnerability is not affected. - Risk to forge contents of encrypted message is very low. - Risk to raise memory corruption is low since jsrsasign uses BigInteger class. Patches Users using RSA PKCS1-v15 or RSA-OAEP decryption should upgrade to 8.0.18. Workarounds Reject RSA PKCS1-v15 or RSA-OAEP encrypted message with unnecessary prepending zeros. References https://nvd.nist.gov/vuln/detail/CVE-2020-14967 https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14967 https://vuldb.com/?id.157124 https://kjur.github.io/jsrsasign/api/symbols/KJUR.crypto.Cipher.html#.decrypt https://github.com/kjur/jsrsasign/issues/439
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xxxq-chmp-67g4
- Revision 1 · created ·
Published from osv record GHSA-xxxq-chmp-67g4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-14967 Advisory: RSA PKCS#1 decryption vulnerability with prepending zeros in jsrsasign IDs: CVE-2020-14967, GHSA-xxxq-chmp-67g4 Record: https://patchnext.com/advisories/cve-2020-14967 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jsrsasign 8.0.18. A vendor fix does not mean a deployment is fixed. ## Affected components - npm jsrsasign: affected < 8.0.18; fixed in 8.0.18 ## Suggested inspection (read-only) - `npm ls jsrsasign --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jsrsasign. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xxxq-chmp-67g4 (OSV record GHSA-xxxq-chmp-67g4 lists affected ranges: npm jsrsasign >=0 <8.0.18 (fixed)) - Verified: https://github.com/advisories/GHSA-xxxq-chmp-67g4 (GitHub-reviewed advisory GHSA-xxxq-chmp-67g4 lists affected ranges: npm jsrsasign >=0 <8.0.18) Commands are suggestions: review each one before running it.
Loading voting…