Dolibarr reflected cross-site scripting (XSS) vulnerability
CVE-2020-14475GHSA-m396-2x3h-v3v4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dolibarr/dolibarr 11.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist dolibarr/dolibarr
- Affected
- < 11.0.5
- Fixed in
- 11.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m396-2x3h-v3v4 lists affected ranges: Packagist dolibarr/dolibarr >=0 <11.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2020-14475: 0.81% estimated exploitation activity in the next 30 days; percentile 56.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A reflected cross-site scripting (XSS) vulnerability in Dolibarr 11.0.4 and below allows remote attackers to inject arbitrary web script or HTML into public/notice.php (related to transphrase and transkey).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m396-2x3h-v3v4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-14475 Advisory: Dolibarr reflected cross-site scripting (XSS) vulnerability IDs: CVE-2020-14475, GHSA-m396-2x3h-v3v4 Record: https://patchnext.com/advisories/cve-2020-14475 (revision 1, source checked 26 Oct 2026, 14:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dolibarr/dolibarr 11.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist dolibarr/dolibarr: affected < 11.0.5; fixed in 11.0.5 ## Suggested inspection (read-only) - Packagist dolibarr/dolibarr: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dolibarr/dolibarr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m396-2x3h-v3v4 (GitHub-reviewed advisory GHSA-m396-2x3h-v3v4 lists affected ranges: Packagist dolibarr/dolibarr >=0 <11.0.5) Commands are suggestions: review each one before running it.
Loading voting…