Apache Superset OS Command Injection
CVE-2020-13948GHSA-cj7g-h7rf-h8j9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-superset 0.37.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-superset
- Affected
- < 0.37.1
- Fixed in
- 0.37.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cj7g-h7rf-h8j9 lists affected ranges: PyPI apache-superset >=0 <0.37.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cj7g-h7rf-h8j9 lists affected ranges: PyPI apache-superset >=0 <0.37.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-13948: 3.10% estimated exploitation activity in the next 30 days; percentile 87.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
While investigating a bug report on Apache Superset, it was determined that an authenticated user could craft requests via a number of templated text fields in the product that would allow arbitrary access to Python’s os package in the web application process in versions < 0.37.1. It was thus possible for an authenticated user to list and access files, environment variables, and process information. Additionally it was possible to set environment variables for the current process, create and update files in folders writable by the web process, and execute arbitrary programs accessible by the web process. All other operations available to the os package in Python were also available, even if not explicitly enumerated in this CVE.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cj7g-h7rf-h8j9
- Revision 1 · created ·
Published from osv record GHSA-cj7g-h7rf-h8j9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-13948 Advisory: Apache Superset OS Command Injection IDs: CVE-2020-13948, GHSA-cj7g-h7rf-h8j9 Record: https://patchnext.com/advisories/cve-2020-13948 (revision 2, source checked 26 Oct 2026, 13:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-superset 0.37.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-superset: affected < 0.37.1; fixed in 0.37.1 ## Suggested inspection (read-only) - `python -m pip show apache-superset`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-superset. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cj7g-h7rf-h8j9 (OSV record GHSA-cj7g-h7rf-h8j9 lists affected ranges: PyPI apache-superset >=0 <0.37.1 (fixed)) - Verified: https://github.com/advisories/GHSA-cj7g-h7rf-h8j9 (GitHub-reviewed advisory GHSA-cj7g-h7rf-h8j9 lists affected ranges: PyPI apache-superset >=0 <0.37.1) Commands are suggestions: review each one before running it.
Loading voting…