Skip to content

← Actionable
Medium, CVSS 5.9

Man-in-the-middle attack in Apache Cassandra

CVE-2020-13946GHSA-24ww-mc5x-xc43

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.cassandra:cassandra-all 4.0-beta2, 3.11.8, 3.0.22, 2.2.18, 2.1.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.cassandra:cassandra-all

    Affected
    >= 2.1.0, < 2.1.12>= 2.2.0, < 2.2.18>= 3.0.0, < 3.0.22>= 3.11.0, < 3.11.8>= 4.0-beta1, <= 4.0-beta1
    Fixed in
    2.1.12, 2.2.18, 3.11.8, 3.0.22, 4.0-beta2

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-24ww-mc5x-xc43 lists affected ranges: Maven org.apache.cassandra:cassandra-all >=2.1.0 =2.2.0 =3.0.0 =3.11.0 =4.0-beta1 <=4.0-beta1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2020-13946: 2.95% estimated exploitation activity in the next 30 days; percentile 87.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Apache Cassandra, all versions prior to 2.1.22, 2.2.18, 3.0.22, 3.11.8 and 4.0-beta2, it is possible for a local attacker without access to the Apache Cassandra process or configuration files to manipulate the RMI registry to perform a man-in-the-middle attack and capture user names and passwords used to access the JMX interface. The attacker can then use these credentials to access the JMX interface and perform unauthorised operations. Users should also be aware of CVE-2019-2684, a JRE vulnerability that enables this issue to be exploited remotely.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-24ww-mc5x-xc43

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-13946

Advisory: Man-in-the-middle attack in Apache Cassandra
IDs: CVE-2020-13946, GHSA-24ww-mc5x-xc43
Record: https://patchnext.com/advisories/cve-2020-13946 (revision 1, source checked 26 Oct 2026, 16:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.cassandra:cassandra-all 4.0-beta2, 3.11.8, 3.0.22, 2.2.18, 2.1.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.cassandra:cassandra-all: affected >= 2.1.0, < 2.1.12; >= 2.2.0, < 2.2.18; >= 3.0.0, < 3.0.22; >= 3.11.0, < 3.11.8; >= 4.0-beta1, <= 4.0-beta1; fixed in 2.1.12, 2.2.18, 3.11.8, 3.0.22, 4.0-beta2

## Suggested inspection (read-only)
- Maven org.apache.cassandra:cassandra-all: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.cassandra:cassandra-all.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-24ww-mc5x-xc43 (GitHub-reviewed advisory GHSA-24ww-mc5x-xc43 lists affected ranges: Maven org.apache.cassandra:cassandra-all >=2.1.0 =2.2.0 =3.0.0 =3.11.0 =4.0-beta1 <=4.0-beta1)

Commands are suggestions: review each one before running it.

Loading voting…