Skip to content

← Actionable
Critical, CVSS 9.3Exploited · CISA KEVamended

Authentication bypass in Apache Airflow

CVE-2020-13927GHSA-hhx9-p69v-cx2j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 1.10.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:A · score source
EPSS
  • CVE-2020-13927: 99.78% estimated exploitation activity in the next 30 days; percentile 99.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The previous default setting for Airflow's Experimental API was to allow all API requests without authentication, but this poses security risks to users who miss this fact. From Airflow 1.10.11 the default has been changed to deny all requests by default and is documented at https://airflow.apache.org/docs/1.10.11/security.html#api-authentication. Note this change fixes it for new installs but existing users need to change their config to default [api]authbackend = airflow.api.auth.backend.denyall as mentioned in the Updating Guide: https://github.com/apache/airflow/blob/1.10.11/UPDATING.md#experimental-api-will-deny-all-request-by-default

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-hhx9-p69v-cx2j

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · evidence added ·

    CISA KEV confirmed exploitation for CVE-2020-13927 (date added 2022-01-18). Customer workflow unchanged.

  4. Revision 1 · created ·

    Published from osv record GHSA-hhx9-p69v-cx2j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-13927

Advisory: Authentication bypass in Apache Airflow
IDs: CVE-2020-13927, GHSA-hhx9-p69v-cx2j
Record: https://patchnext.com/advisories/cve-2020-13927 (revision 4, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow 1.10.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow: affected < 1.10.11; fixed in 1.10.11

## Suggested inspection (read-only)
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hhx9-p69v-cx2j (OSV record GHSA-hhx9-p69v-cx2j lists affected ranges: PyPI apache-airflow >=0 <1.10.11 (fixed))
- Verified: https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json (CISA added CVE-2020-13927 to the Known Exploited Vulnerabilities catalog on 2022-01-18.)
- Verified: https://github.com/advisories/GHSA-hhx9-p69v-cx2j (GitHub-reviewed advisory GHSA-hhx9-p69v-cx2j lists affected ranges: PyPI apache-airflow >=0 <1.10.11)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2020-13927 to the Known Exploited Vulnerabilities catalog on 2022-01-18.)

Commands are suggestions: review each one before running it.

Loading voting…