SQL Injection in Apache SkyWalking
CVE-2020-13921GHSA-grpf-gg7v-5g5h
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-skywalking
- Affected
- every version
- Fixed in
- no fixed version recorded
Maven org.apache.skywalking:oap-server
- Affected
- < 8.1.0
- Fixed in
- 8.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2020-342 lists affected ranges: PyPI apache-skywalking >=0
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-grpf-gg7v-5g5h lists affected ranges: Maven org.apache.skywalking:oap-server >=0 <8.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-13921: 33.48% estimated exploitation activity in the next 30 days; percentile 98.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Only when using H2/MySQL/TiDB as Apache SkyWalking storage, there is a SQL injection vulnerability in the wildcard query cases.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-grpf-gg7v-5g5h
- Revision 1 · created ·
Published from osv record PYSEC-2020-342
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-13921 Advisory: SQL Injection in Apache SkyWalking IDs: CVE-2020-13921, GHSA-grpf-gg7v-5g5h Record: https://patchnext.com/advisories/cve-2020-13921 (revision 2, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.skywalking:oap-server 8.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-skywalking: affected every version - Maven org.apache.skywalking:oap-server: affected < 8.1.0; fixed in 8.1.0 ## Suggested inspection (read-only) - `python -m pip show apache-skywalking`: prints the installed version. Run with the environment that serves production active. - Maven org.apache.skywalking:oap-server: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-skywalking, org.apache.skywalking:oap-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2020-342 (OSV record PYSEC-2020-342 lists affected ranges: PyPI apache-skywalking >=0) - Verified: https://github.com/advisories/GHSA-grpf-gg7v-5g5h (GitHub-reviewed advisory GHSA-grpf-gg7v-5g5h lists affected ranges: Maven org.apache.skywalking:oap-server >=0 <8.1.0) Commands are suggestions: review each one before running it.
Loading voting…