Skip to content

← Actionable
High, CVSS 7.7amended

Signature Malleabillity in elliptic

CVE-2020-13822GHSA-vh7m-p724-62c2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (elliptic 6.5.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm elliptic

    Affected
    < 6.5.3
    Fixed in
    6.5.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2020-13822: 2.71% estimated exploitation activity in the next 30 days; percentile 85.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Elliptic package before version 6.5.3 for Node.js allows ECDSA signature malleability via variations in encoding, leading '\0' bytes, or integer overflows. This could conceivably have a security-relevant impact if an application relied on a single canonical signature.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vh7m-p724-62c2

  2. Revision 1 · created ·

    Published from osv record GHSA-vh7m-p724-62c2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-13822

Advisory: Signature Malleabillity in elliptic
IDs: CVE-2020-13822, GHSA-vh7m-p724-62c2
Record: https://patchnext.com/advisories/cve-2020-13822 (revision 2, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: elliptic 6.5.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm elliptic: affected < 6.5.3; fixed in 6.5.3

## Suggested inspection (read-only)
- `npm ls elliptic --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on elliptic.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vh7m-p724-62c2 (OSV record GHSA-vh7m-p724-62c2 lists affected ranges: npm elliptic >=0 <6.5.3 (fixed))
- Verified: https://github.com/advisories/GHSA-vh7m-p724-62c2 (GitHub-reviewed advisory GHSA-vh7m-p724-62c2 lists affected ranges: npm elliptic >=0 <6.5.3)

Commands are suggestions: review each one before running it.

Loading voting…