Authenticated users can exploit an enumeration vulnerability in Harbor
CVE-2020-13794GHSA-q9p8-33wc-h432
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/goharbor/harbor 2.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.0.3
- Fixed in
- 2.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q9p8-33wc-h432 lists affected ranges: Go github.com/goharbor/harbor >=0 <2.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2020-13794: 1.27% estimated exploitation activity in the next 30 days; percentile 69.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Hidde Smit from Cyber Eagle has discovered an User Enumeration flaw in Harbor. The issue is present in the "/users" api endpoint. This endpoint is supposed to be restricted to administrators. This restriction is able to be bypassed and information can be obtained via the "search" functionality. Non-administrator users (such as those created via self-registration) can list all usernames and user IDs by sending a GET request to /api/users/search with parameter "username" and value "", as follows: curl -X GET "https://<host/api/users/search?username=" -H "accept: application/json" --user <user:<password The vulnerability was immediately fixed by the Harbor team and all supported versions were patched. With the patched versions of Harbor, the username is required for search and we have removed the support for querying by email. Patches If your product uses the affected releases of Harbor, update to either version 2.1.0 or 2.0.3 to fix this issue immediately…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q9p8-33wc-h432
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-13794 Advisory: Authenticated users can exploit an enumeration vulnerability in Harbor IDs: CVE-2020-13794, GHSA-q9p8-33wc-h432 Record: https://patchnext.com/advisories/cve-2020-13794 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/goharbor/harbor 2.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/goharbor/harbor: affected < 2.0.3; fixed in 2.0.3 ## Suggested inspection (read-only) - Go github.com/goharbor/harbor: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/goharbor/harbor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q9p8-33wc-h432 (GitHub-reviewed advisory GHSA-q9p8-33wc-h432 lists affected ranges: Go github.com/goharbor/harbor >=0 <2.0.3) Commands are suggestions: review each one before running it.
Loading voting…