Drupal Core Cross-site scripting vulnerability
CVE-2020-13688GHSA-qf2g-mrrx-rr5p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 9.0.6, 8.9.6, 8.8.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/core
- Affected
- >= 8.8.0, < 8.8.10>= 8.9.0, < 8.9.6>= 9.0.0, < 9.0.6
- Fixed in
- 9.0.6, 8.9.6, 8.8.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qf2g-mrrx-rr5p lists affected ranges: Packagist drupal/core >=8.8.0 =8.9.0 =9.0.0 <9.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2020-13688: 0.66% estimated exploitation activity in the next 30 days; percentile 51.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting vulnerability in Drupal Core allows an attacker could leverage the way that HTML is rendered for affected forms in order to exploit the vulnerability. This issue affects: Drupal Core 8.8.X versions prior to 8.8.10; 8.9.X versions prior to 8.9.6; 9.0.X versions prior to 9.0.6.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qf2g-mrrx-rr5p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-13688 Advisory: Drupal Core Cross-site scripting vulnerability IDs: CVE-2020-13688, GHSA-qf2g-mrrx-rr5p Record: https://patchnext.com/advisories/cve-2020-13688 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drupal/core 9.0.6, 8.9.6, 8.8.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/core: affected >= 8.8.0, < 8.8.10; >= 8.9.0, < 8.9.6; >= 9.0.0, < 9.0.6; fixed in 9.0.6, 8.9.6, 8.8.10 ## Suggested inspection (read-only) - Packagist drupal/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qf2g-mrrx-rr5p (GitHub-reviewed advisory GHSA-qf2g-mrrx-rr5p lists affected ranges: Packagist drupal/core >=8.8.0 =8.9.0 =9.0.0 <9.0.6) Commands are suggestions: review each one before running it.
Loading voting…