Skip to content

← Actionable
Medium, CVSS 6.1

Drupal core Cross-site Scripting (XSS) vulnerability

CVE-2020-13672GHSA-3m36-mjwj-352c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 9.1.7, 9.0.12, 8.9.14, 7.80; drupal/drupal 9.1.7, 9.0.12, 8.9.14, 7.80), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 7.0.0, < 7.80>= 8.0.0, < 8.9.14>= 9.0.0, < 9.0.12>= 9.1.0, < 9.1.7
    Fixed in
    7.80, 9.1.7, 8.9.14, 9.0.12
  • Packagist drupal/drupal

    Affected
    >= 7.0.0, < 7.80>= 8.0.0, < 8.9.14>= 9.0.0, < 9.0.12>= 9.1.0, < 9.1.7
    Fixed in
    7.80, 9.1.7, 8.9.14, 9.0.12

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-3m36-mjwj-352c lists affected ranges: Packagist drupal/core >=7.0.0 =8.0.0 =9.0.0 =9.1.0 =7.0.0 =8.0.0 =9.0.0 =9.1.0 <9.1.7

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2020-13672: 0.68% estimated exploitation activity in the next 30 days; percentile 52.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-site Scripting (XSS) vulnerability in Drupal core's sanitization API fails to properly filter cross-site scripting under certain circumstances. This issue affects: Drupal Core 9.1.x versions prior to 9.1.7; 9.0.x versions prior to 9.0.12; 8.9.x versions prior to 8.9.14; 7.x versions prior to 7.80.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3m36-mjwj-352c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-13672

Advisory: Drupal core Cross-site Scripting (XSS) vulnerability
IDs: CVE-2020-13672, GHSA-3m36-mjwj-352c
Record: https://patchnext.com/advisories/cve-2020-13672 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 9.1.7, 9.0.12, 8.9.14, 7.80; drupal/drupal 9.1.7, 9.0.12, 8.9.14, 7.80. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 7.0.0, < 7.80; >= 8.0.0, < 8.9.14; >= 9.0.0, < 9.0.12; >= 9.1.0, < 9.1.7; fixed in 7.80, 9.1.7, 8.9.14, 9.0.12
- Packagist drupal/drupal: affected >= 7.0.0, < 7.80; >= 8.0.0, < 8.9.14; >= 9.0.0, < 9.0.12; >= 9.1.0, < 9.1.7; fixed in 7.80, 9.1.7, 8.9.14, 9.0.12

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3m36-mjwj-352c (GitHub-reviewed advisory GHSA-3m36-mjwj-352c lists affected ranges: Packagist drupal/core >=7.0.0 =8.0.0 =9.0.0 =9.1.0 =7.0.0 =8.0.0 =9.0.0 =9.1.0 <9.1.7)

Commands are suggestions: review each one before running it.

Loading voting…