Skip to content

← Actionable
High, CVSS 7.5

Exposure of Resource to Wrong Sphere in Drupal Core

CVE-2020-13670GHSA-mmjr-5q74-p3m4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 9.0.6, 8.9.6, 8.8.10; drupal/drupal 9.0.6, 8.9.6, 8.8.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 8.9.0, < 8.9.6>= 9.0.0, < 9.0.6>= 8.0.0, < 8.8.10
    Fixed in
    9.0.6, 8.9.6, 8.8.10
  • Packagist drupal/drupal

    Affected
    >= 8.0.0, < 8.8.10>= 8.9.0, < 8.9.6>= 9.0.0, < 9.0.6
    Fixed in
    9.0.6, 8.9.6, 8.8.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2020-13670: 1.11% estimated exploitation activity in the next 30 days; percentile 65.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Information Disclosure vulnerability in file module of Drupal Core allows an attacker to gain access to the file metadata of a permanent private file that they do not have access to by guessing the ID of the file. This issue affects: Drupal Core 8.8.x versions prior to 8.8.10; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mmjr-5q74-p3m4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-13670

Advisory: Exposure of Resource to Wrong Sphere in Drupal Core
IDs: CVE-2020-13670, GHSA-mmjr-5q74-p3m4
Record: https://patchnext.com/advisories/cve-2020-13670 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 9.0.6, 8.9.6, 8.8.10; drupal/drupal 9.0.6, 8.9.6, 8.8.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 8.9.0, < 8.9.6; >= 9.0.0, < 9.0.6; >= 8.0.0, < 8.8.10; fixed in 9.0.6, 8.9.6, 8.8.10
- Packagist drupal/drupal: affected >= 8.0.0, < 8.8.10; >= 8.9.0, < 8.9.6; >= 9.0.0, < 9.0.6; fixed in 9.0.6, 8.9.6, 8.8.10

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mmjr-5q74-p3m4 (GitHub-reviewed advisory GHSA-mmjr-5q74-p3m4 lists affected ranges: Packagist drupal/core >=8.9.0 =9.0.0 =8.0.0 =8.0.0 =8.9.0 =9.0.0 <9.0.6)

Commands are suggestions: review each one before running it.

Loading voting…