Skip to content

← Actionable
Medium, CVSS 6.1

Drupal core Cross-site Scripting (XSS) vulnerability in ckeditor

CVE-2020-13669GHSA-c533-c843-67h8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 9.0.6, 8.9.6, 8.8.10; drupal/drupal 9.0.6, 8.9.6, 8.8.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 8.0.0, < 8.8.10>= 8.9.0, < 8.9.6>= 9.0.0, < 9.0.6
    Fixed in
    9.0.6, 8.9.6, 8.8.10
  • Packagist drupal/drupal

    Affected
    >= 8.0.0, < 8.8.10>= 8.9.0, < 8.9.6>= 9.0.0, < 9.0.6
    Fixed in
    9.0.6, 8.9.6, 8.8.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2020-13669: 0.74% estimated exploitation activity in the next 30 days; percentile 54.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-site Scripting (XSS) vulnerability in ckeditor of Drupal Core allows attacker to inject XSS. This issue affects: Drupal Core 8.8.x versions prior to 8.8.10.; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c533-c843-67h8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-13669

Advisory: Drupal core Cross-site Scripting (XSS) vulnerability in ckeditor
IDs: CVE-2020-13669, GHSA-c533-c843-67h8
Record: https://patchnext.com/advisories/cve-2020-13669 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 9.0.6, 8.9.6, 8.8.10; drupal/drupal 9.0.6, 8.9.6, 8.8.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 8.0.0, < 8.8.10; >= 8.9.0, < 8.9.6; >= 9.0.0, < 9.0.6; fixed in 9.0.6, 8.9.6, 8.8.10
- Packagist drupal/drupal: affected >= 8.0.0, < 8.8.10; >= 8.9.0, < 8.9.6; >= 9.0.0, < 9.0.6; fixed in 9.0.6, 8.9.6, 8.8.10

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c533-c843-67h8 (GitHub-reviewed advisory GHSA-c533-c843-67h8 lists affected ranges: Packagist drupal/core >=8.0.0 =8.9.0 =9.0.0 =8.0.0 =8.9.0 =9.0.0 <9.0.6)

Commands are suggestions: review each one before running it.

Loading voting…