Skip to content

← Actionable
Medium, CVSS 6.1

Drupal Core Cross-site scripting vulnerability

CVE-2020-13666GHSA-8jj2-x2gc-ggm7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 9.0.6, 8.9.6, 8.8.10, 7.73; drupal/drupal 9.0.6, 8.9.6, 8.8.10, 7.73), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 8.8.0, < 8.8.10>= 8.9.0, < 8.9.6>= 9.0.0, < 9.0.6>= 7.0.0, < 7.73
    Fixed in
    7.73, 9.0.6, 8.9.6, 8.8.10
  • Packagist drupal/drupal

    Affected
    >= 7.0.0, < 7.73>= 8.8.0, < 8.8.10>= 8.9.0, < 8.9.6>= 9.0.0, < 9.0.6
    Fixed in
    7.73, 9.0.6, 8.9.6, 8.8.10

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-8jj2-x2gc-ggm7 lists affected ranges: Packagist drupal/core >=8.8.0 =8.9.0 =9.0.0 =7.0.0 =7.0.0 =8.8.0 =8.9.0 =9.0.0 <9.0.6

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2020-13666: 2.93% estimated exploitation activity in the next 30 days; percentile 87.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-site scripting vulnerability in Drupal Core. Drupal AJAX API does not disable JSONP by default, allowing for an XSS attack. This issue affects: Drupal Drupal Core 7.x versions prior to 7.73; 8.8.x versions prior to 8.8.10; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8jj2-x2gc-ggm7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-13666

Advisory: Drupal Core Cross-site scripting vulnerability
IDs: CVE-2020-13666, GHSA-8jj2-x2gc-ggm7
Record: https://patchnext.com/advisories/cve-2020-13666 (revision 1, source checked 26 Oct 2026, 14:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 9.0.6, 8.9.6, 8.8.10, 7.73; drupal/drupal 9.0.6, 8.9.6, 8.8.10, 7.73. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 8.8.0, < 8.8.10; >= 8.9.0, < 8.9.6; >= 9.0.0, < 9.0.6; >= 7.0.0, < 7.73; fixed in 7.73, 9.0.6, 8.9.6, 8.8.10
- Packagist drupal/drupal: affected >= 7.0.0, < 7.73; >= 8.8.0, < 8.8.10; >= 8.9.0, < 8.9.6; >= 9.0.0, < 9.0.6; fixed in 7.73, 9.0.6, 8.9.6, 8.8.10

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8jj2-x2gc-ggm7 (GitHub-reviewed advisory GHSA-8jj2-x2gc-ggm7 lists affected ranges: Packagist drupal/core >=8.8.0 =8.9.0 =9.0.0 =7.0.0 =7.0.0 =8.8.0 =8.9.0 =9.0.0 <9.0.6)

Commands are suggestions: review each one before running it.

Loading voting…