Skip to content

← Actionable
Critical, CVSS 9.8

Drupal Core Access bypass vulnerability

CVE-2020-13665GHSA-wxqp-jwc9-g39x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 9.0.1, 8.9.1, 8.8.8; drupal/drupal 9.0.1, 8.9.1, 8.8.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 8.8.0, < 8.8.8>= 8.9.0, < 8.9.1>= 9.0.0, < 9.0.1
    Fixed in
    8.9.1, 8.8.8, 9.0.1
  • Packagist drupal/drupal

    Affected
    >= 8.8.0, < 8.8.8>= 8.9.0, < 8.9.1>= 9.0.0, < 9.0.1
    Fixed in
    8.9.1, 8.8.8, 9.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-13665: 1.27% estimated exploitation activity in the next 30 days; percentile 69.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Access bypass vulnerability in Drupal Core allows JSON:API when JSON:API is in read/write mode. Only sites that have the readonly set to FALSE under jsonapi.settings config are vulnerable. This issue affects: Drupal Drupal Core 8.8.x versions prior to 8.8.8; 8.9.x versions prior to 8.9.1; 9.0.x versions prior to 9.0.1.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wxqp-jwc9-g39x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-13665

Advisory: Drupal Core Access bypass vulnerability
IDs: CVE-2020-13665, GHSA-wxqp-jwc9-g39x
Record: https://patchnext.com/advisories/cve-2020-13665 (revision 1, source checked 26 Oct 2026, 14:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 9.0.1, 8.9.1, 8.8.8; drupal/drupal 9.0.1, 8.9.1, 8.8.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 8.8.0, < 8.8.8; >= 8.9.0, < 8.9.1; >= 9.0.0, < 9.0.1; fixed in 8.9.1, 8.8.8, 9.0.1
- Packagist drupal/drupal: affected >= 8.8.0, < 8.8.8; >= 8.9.0, < 8.9.1; >= 9.0.0, < 9.0.1; fixed in 8.9.1, 8.8.8, 9.0.1

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wxqp-jwc9-g39x (GitHub-reviewed advisory GHSA-wxqp-jwc9-g39x lists affected ranges: Packagist drupal/core >=8.8.0 =8.9.0 =9.0.0 =8.8.0 =8.9.0 =9.0.0 <9.0.1)

Commands are suggestions: review each one before running it.

Loading voting…