Skip to content

← Actionable
High, CVSS 8.8

Drupal Core Cross-Site Request Forgery (CSRF) vulnerability

CVE-2020-13663GHSA-m648-hpf8-qcjw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 9.0.1, 8.9.1, 8.8.8, 7.72; drupal/drupal 9.0.1, 8.9.1, 8.8.8, 7.72), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 8.9.0, < 8.9.1>= 9.0.0, < 9.0.1>= 7.0.0, < 7.72>= 8.0.0, < 8.8.8
    Fixed in
    7.72, 8.9.1, 8.8.8, 9.0.1
  • Packagist drupal/drupal

    Affected
    >= 7.0.0, < 7.72>= 8.0.0, < 8.8.8>= 8.9.0, < 8.9.1>= 9.0.0, < 9.0.1
    Fixed in
    7.72, 8.9.1, 8.8.8, 9.0.1

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-m648-hpf8-qcjw lists affected ranges: Packagist drupal/core >=8.9.0 =9.0.0 =7.0.0 =8.0.0 =7.0.0 =8.0.0 =8.9.0 =9.0.0 <9.0.1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-13663: 0.69% estimated exploitation activity in the next 30 days; percentile 53.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross Site Request Forgery vulnerability in Drupal Core Form API does not properly handle certain form input from cross-site requests, which can lead to other vulnerabilities.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m648-hpf8-qcjw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-13663

Advisory: Drupal Core Cross-Site Request Forgery (CSRF) vulnerability
IDs: CVE-2020-13663, GHSA-m648-hpf8-qcjw
Record: https://patchnext.com/advisories/cve-2020-13663 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 9.0.1, 8.9.1, 8.8.8, 7.72; drupal/drupal 9.0.1, 8.9.1, 8.8.8, 7.72. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 8.9.0, < 8.9.1; >= 9.0.0, < 9.0.1; >= 7.0.0, < 7.72; >= 8.0.0, < 8.8.8; fixed in 7.72, 8.9.1, 8.8.8, 9.0.1
- Packagist drupal/drupal: affected >= 7.0.0, < 7.72; >= 8.0.0, < 8.8.8; >= 8.9.0, < 8.9.1; >= 9.0.0, < 9.0.1; fixed in 7.72, 8.9.1, 8.8.8, 9.0.1

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m648-hpf8-qcjw (GitHub-reviewed advisory GHSA-m648-hpf8-qcjw lists affected ranges: Packagist drupal/core >=8.9.0 =9.0.0 =7.0.0 =8.0.0 =7.0.0 =8.0.0 =8.9.0 =9.0.0 <9.0.1)

Commands are suggestions: review each one before running it.

Loading voting…