Skip to content

← Actionable
High, CVSS 7.5

Insufficient output escaping of attachment names in PHPMailer

CVE-2020-13625GHSA-f7hx-fqxw-rvvj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmailer/phpmailer 6.1.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2020-13625: 3.78% estimated exploitation activity in the next 30 days; percentile 89.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact CWE-116: Incorrect output escaping. An attachment added like this (note the double quote within the attachment name, which is entirely valid): $mail-addAttachment('/tmp/attachment.tmp', 'filename.html";.jpg'); Will result in a message containing these headers: Content-Type: application/octet-stream; name="filename.html";.jpg" Content-Disposition: attachment; filename="filename.html";.jpg" The attachment will be named filename.html, and the trailing ";.jpg" will be ignored. Mail filters that reject .html attachments but permit .jpg attachments may be fooled by this. Note that the MIME type itself is obtained automatically from the source filename (in this case attachment.tmp, which maps to a generic application/octet-stream type), and not the name given to the attachment (though these are the same if a separate name is not provided), though it can be set explicitly in other parameters to attachment methods. Patches Patched in PHPMailer 6.1.6 by escaping double quotes within the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f7hx-fqxw-rvvj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-13625

Advisory: Insufficient output escaping of attachment names in PHPMailer
IDs: CVE-2020-13625, GHSA-f7hx-fqxw-rvvj
Record: https://patchnext.com/advisories/cve-2020-13625 (revision 1, source checked 26 Oct 2026, 13:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpmailer/phpmailer 6.1.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpmailer/phpmailer: affected < 6.1.6; fixed in 6.1.6

## Suggested inspection (read-only)
- Packagist phpmailer/phpmailer: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpmailer/phpmailer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f7hx-fqxw-rvvj (GitHub-reviewed advisory GHSA-f7hx-fqxw-rvvj lists affected ranges: Packagist phpmailer/phpmailer >=0 <6.1.6)

Commands are suggestions: review each one before running it.

Loading voting…