Information Disclosure in HashiCorp Vault
CVE-2020-13223GHSA-25xj-89g5-fm6h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/vault 1.4.2, 1.3.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.3.0, < 1.3.6>= 1.4.0, < 1.4.2
- Fixed in
- 1.4.2, 1.3.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-25xj-89g5-fm6h lists affected ranges: Go github.com/hashicorp/vault >=1.3.0 =1.4.0 <1.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2020-13223: 1.26% estimated exploitation activity in the next 30 days; percentile 69.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
HashiCorp Vault and Vault Enterprise before 1.3.6, and 1.4.2 before 1.4.2, insert Sensitive Information into a Log File. The vulnerability is affecting github.com/hashicorp/vault/command Go package.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-25xj-89g5-fm6h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-13223 Advisory: Information Disclosure in HashiCorp Vault IDs: CVE-2020-13223, GHSA-25xj-89g5-fm6h Record: https://patchnext.com/advisories/cve-2020-13223 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/vault 1.4.2, 1.3.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hashicorp/vault: affected >= 1.3.0, < 1.3.6; >= 1.4.0, < 1.4.2; fixed in 1.4.2, 1.3.6 ## Suggested inspection (read-only) - Go github.com/hashicorp/vault: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hashicorp/vault. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-25xj-89g5-fm6h (GitHub-reviewed advisory GHSA-25xj-89g5-fm6h lists affected ranges: Go github.com/hashicorp/vault >=1.3.0 =1.4.0 <1.4.2) Commands are suggestions: review each one before running it.
Loading voting…