Skip to content

← Actionable
High, CVSS 7.8amended

DLL Injection in kerberos

CVE-2020-13110GHSA-m2mx-rfpw-jghv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kerberos 1.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm kerberos

    Affected
    < 1.0.0
    Fixed in
    1.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-13110: 0.74% estimated exploitation activity in the next 30 days; percentile 54.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Version of kerberos prior to 1.0.0 are vulnerable to DLL Injection. The package loads DLLs without specifying a full path. This may allow attackers to create a file with the same name in a folder that precedes the intended file in the DLL path search. Doing so would allow attackers to execute arbitrary code in the machine. Recommendation Upgrade to version 1.0.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m2mx-rfpw-jghv

  2. Revision 1 · created ·

    Published from osv record GHSA-m2mx-rfpw-jghv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-13110

Advisory: DLL Injection in kerberos
IDs: CVE-2020-13110, GHSA-m2mx-rfpw-jghv
Record: https://patchnext.com/advisories/cve-2020-13110 (revision 2, source checked 26 Oct 2026, 12:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kerberos 1.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm kerberos: affected < 1.0.0; fixed in 1.0.0

## Suggested inspection (read-only)
- `npm ls kerberos --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kerberos.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m2mx-rfpw-jghv (OSV record GHSA-m2mx-rfpw-jghv lists affected ranges: npm kerberos >=0 <1.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-m2mx-rfpw-jghv (GitHub-reviewed advisory GHSA-m2mx-rfpw-jghv lists affected ranges: npm kerberos >=0 <1.0.0)

Commands are suggestions: review each one before running it.

Loading voting…