Skip to content

← Actionable
High, CVSS 8.8

OpenNMS Horizon RCE via Unsafe Deserialization

CVE-2020-12760GHSA-853f-x27w-8r74

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opennms.core:org.opennms.core.daemon 26.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-12760: 3.46% estimated exploitation activity in the next 30 days; percentile 89.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in OpenNMS Horizon before 26.0.1, and Meridian before 2018.1.19 and 2019 before 2019.1.7. The ActiveMQ channel configuration allowed for arbitrary deserialization of Java objects (aka ActiveMQ Minion payload deserialization), leading to remote code execution for any authenticated channel user regardless of its assigned permissions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-853f-x27w-8r74

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-12760

Advisory: OpenNMS Horizon RCE via Unsafe Deserialization
IDs: CVE-2020-12760, GHSA-853f-x27w-8r74
Record: https://patchnext.com/advisories/cve-2020-12760 (revision 1, source checked 26 Oct 2026, 16:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.opennms.core:org.opennms.core.daemon 26.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.opennms.core:org.opennms.core.daemon: affected < 26.0.1; fixed in 26.0.1

## Suggested inspection (read-only)
- Maven org.opennms.core:org.opennms.core.daemon: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.opennms.core:org.opennms.core.daemon.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-853f-x27w-8r74 (GitHub-reviewed advisory GHSA-853f-x27w-8r74 lists affected ranges: Maven org.opennms.core:org.opennms.core.daemon >=0 <26.0.1)

Commands are suggestions: review each one before running it.

Loading voting…