Insufficient Session Expiration in OpenStack Keystone
CVE-2020-12690GHSA-6m8p-x4qw-gh5j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (keystone 16.0.0, 15.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI keystone
- Affected
- < 15.0.1>= 16.0.0.0rc1, < 16.0.0
- Fixed in
- 15.0.1, 16.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6m8p-x4qw-gh5j lists affected ranges: PyPI keystone >=0 =16.0.0.0rc1 <16.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6m8p-x4qw-gh5j lists affected ranges: PyPI keystone >=0 =16.0.0.0rc1 <16.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2020-12690: 1.90% estimated exploitation activity in the next 30 days; percentile 79.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in OpenStack Keystone before 15.0.1, and 16.0.0. The list of roles provided for an OAuth1 access token is silently ignored. Thus, when an access token is used to request a keystone token, the keystone token contains every role assignment the creator had for the project. This results in the provided keystone token having more role assignments than the creator intended, possibly giving unintended escalated access.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6m8p-x4qw-gh5j
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-6m8p-x4qw-gh5j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-12690 Advisory: Insufficient Session Expiration in OpenStack Keystone IDs: CVE-2020-12690, GHSA-6m8p-x4qw-gh5j Record: https://patchnext.com/advisories/cve-2020-12690 (revision 3, source checked 26 Oct 2026, 13:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: keystone 16.0.0, 15.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI keystone: affected < 15.0.1; >= 16.0.0.0rc1, < 16.0.0; fixed in 15.0.1, 16.0.0 ## Suggested inspection (read-only) - `python -m pip show keystone`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on keystone. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6m8p-x4qw-gh5j (OSV record GHSA-6m8p-x4qw-gh5j lists affected ranges: PyPI keystone >=0 =16.0.0.0rc1 <16.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-6m8p-x4qw-gh5j (GitHub-reviewed advisory GHSA-6m8p-x4qw-gh5j lists affected ranges: PyPI keystone >=0 =16.0.0.0rc1 <16.0.0) Commands are suggestions: review each one before running it.
Loading voting…