Skip to content

← Actionable
Medium, CVSS 6.1amended

Cross-site scripting vulnerability in TinyMCE

CVE-2020-12648GHSA-vrv8-v4w8-f95h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tinymce 5.4.1, 4.9.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm tinymce

    Affected
    < 4.9.11>= 5.0.0, < 5.4.1
    Fixed in
    4.9.11, 5.4.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2020-12648: 1.80% estimated exploitation activity in the next 30 days; percentile 78.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A cross-site scripting (XSS) vulnerability was discovered in the core parser. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.10 or lower and TinyMCE 5.4.0 or lower. Patches This vulnerability has been patched in TinyMCE 4.9.11 and 5.4.1 by improved HTML parsing and sanitization logic. Workarounds The workarounds available are: - upgrade to either TinyMCE 4.9.11 or TinyMCE 5.4.1 or - enable the media plugin, which overrides the default parsing behaviour for iframes or - add the following workaround to update the parsing schema rules for iframes: Example: Change the default schema for iframes Acknowledgements Tiny Technologies would like to thank George Steketee and Chris Davis at Bishop Fox for discovering this vulnerability. References https://www.tiny.cloud/docs/release-notes/release-notes54/#securityfixes For more…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vrv8-v4w8-f95h

  2. Revision 1 · created ·

    Published from osv record GHSA-vrv8-v4w8-f95h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-12648

Advisory: Cross-site scripting vulnerability in TinyMCE
IDs: CVE-2020-12648, GHSA-vrv8-v4w8-f95h
Record: https://patchnext.com/advisories/cve-2020-12648 (revision 2, source checked 26 Oct 2026, 12:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tinymce 5.4.1, 4.9.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm tinymce: affected < 4.9.11; >= 5.0.0, < 5.4.1; fixed in 4.9.11, 5.4.1

## Suggested inspection (read-only)
- `npm ls tinymce --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tinymce.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vrv8-v4w8-f95h (OSV record GHSA-vrv8-v4w8-f95h lists affected ranges: npm tinymce >=0 =5.0.0 <5.4.1 (fixed))
- Verified: https://github.com/advisories/GHSA-vrv8-v4w8-f95h (GitHub-reviewed advisory GHSA-vrv8-v4w8-f95h lists affected ranges: npm tinymce >=0 =5.0.0 <5.4.1)

Commands are suggestions: review each one before running it.

Loading voting…