Skip to content

← Actionable
High, CVSS 7.5

XXE vulnerability in Launch import

CVE-2020-12642GHSA-2jx8-v4hv-gx3h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.epam.reportportal:service-api 5.1.1, 4.3.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2020-12642: 1.38% estimated exploitation activity in the next 30 days; percentile 72.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

| Release Date | Affected Projects | Affected Versions | Access Vector| Security Risk | |--------------|-------------------|-------------------|---------------|---------------| | Monday, May 4, 2020| service-api | Every version, starting from 3.1.0 | Remote | Medium | Impact Starting from version 3.1.0 we introduced a new feature of JUnit XML launch import. Unfortunately XML parser was not configured properly to prevent XML external entity (XXE) attacks. This allows a user to import a specifically-crafted XML file that uses external entities for extraction of secrets from Report Portal service-api module or server-side request forgery. Report Portal versions 4.3.12+ and 5.1.1+ disables external entity resolution for theirs XML parser. We advise our users install the latest releases we built specifically to address this issue. Patches Fixed with https://github.com/reportportal/service-api/pull/1201 Binary Download https://bintray.com/epam/reportportal/service-api/5.1.1…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2jx8-v4hv-gx3h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-12642

Advisory: XXE vulnerability in Launch import
IDs: CVE-2020-12642, GHSA-2jx8-v4hv-gx3h
Record: https://patchnext.com/advisories/cve-2020-12642 (revision 1, source checked 26 Oct 2026, 16:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.epam.reportportal:service-api 5.1.1, 4.3.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.epam.reportportal:service-api: affected >= 3.1.0, < 4.3.12; >= 5.0.0, < 5.1.1; fixed in 4.3.12, 5.1.1

## Suggested inspection (read-only)
- Maven com.epam.reportportal:service-api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.epam.reportportal:service-api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2jx8-v4hv-gx3h (GitHub-reviewed advisory GHSA-2jx8-v4hv-gx3h lists affected ranges: Maven com.epam.reportportal:service-api >=3.1.0 =5.0.0 <5.1.1)

Commands are suggestions: review each one before running it.

Loading voting…