Path Traversal in decompress
CVE-2020-12265GHSA-qgfr-5hqp-vrw9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (decompress 4.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm decompress
- Affected
- < 4.2.1
- Fixed in
- 4.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qgfr-5hqp-vrw9 lists affected ranges: npm decompress >=0 <4.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qgfr-5hqp-vrw9 lists affected ranges: npm decompress >=0 <4.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-12265: 2.12% estimated exploitation activity in the next 30 days; percentile 81.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of decompress prior to 4.2.1 are vulnerable to Arbitrary File Write. The package fails to prevent extraction of files with relative paths, allowing attackers to write to any folder in the system by including filenames containing../. Recommendation Upgrade to version 4.2.1 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qgfr-5hqp-vrw9
- Revision 1 · created ·
Published from osv record GHSA-qgfr-5hqp-vrw9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-12265 Advisory: Path Traversal in decompress IDs: CVE-2020-12265, GHSA-qgfr-5hqp-vrw9 Record: https://patchnext.com/advisories/cve-2020-12265 (revision 2, source checked 26 Oct 2026, 12:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: decompress 4.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm decompress: affected < 4.2.1; fixed in 4.2.1 ## Suggested inspection (read-only) - `npm ls decompress --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on decompress. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qgfr-5hqp-vrw9 (OSV record GHSA-qgfr-5hqp-vrw9 lists affected ranges: npm decompress >=0 <4.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-qgfr-5hqp-vrw9 (GitHub-reviewed advisory GHSA-qgfr-5hqp-vrw9 lists affected ranges: npm decompress >=0 <4.2.1) Commands are suggestions: review each one before running it.
Loading voting…