Skip to content

← Actionable
High, CVSS 8.7Exploited · CISA KEVamended

Remote code execution (RCE) in Apache Airflow

CVE-2020-11978GHSA-rvmq-4x66-q7j3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 1.10.11rc1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:A · score source
EPSS
  • CVE-2020-11978: 99.19% estimated exploitation activity in the next 30 days; percentile 99.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was found in Apache Airflow versions 1.10.10 and below. A remote code/command injection vulnerability was discovered in one of the example DAGs shipped with Airflow which would allow any authenticated user to run arbitrary commands as the user running airflow worker/scheduler (depending on the executor in use). If you already have examples disabled by setting loadexamples=False in the config then you are not vulnerable.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-rvmq-4x66-q7j3

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · evidence added ·

    CISA KEV confirmed exploitation for CVE-2020-11978 (date added 2022-01-18). Customer workflow unchanged.

  4. Revision 1 · created ·

    Published from osv record GHSA-rvmq-4x66-q7j3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-11978

Advisory: Remote code execution (RCE) in Apache Airflow
IDs: CVE-2020-11978, GHSA-rvmq-4x66-q7j3
Record: https://patchnext.com/advisories/cve-2020-11978 (revision 4, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow 1.10.11rc1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow: affected < 1.10.11rc1; fixed in 1.10.11rc1

## Suggested inspection (read-only)
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rvmq-4x66-q7j3 (OSV record GHSA-rvmq-4x66-q7j3 lists affected ranges: PyPI apache-airflow >=0 <1.10.11rc1 (fixed))
- Verified: https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json (CISA added CVE-2020-11978 to the Known Exploited Vulnerabilities catalog on 2022-01-18.)
- Verified: https://github.com/advisories/GHSA-rvmq-4x66-q7j3 (GitHub-reviewed advisory GHSA-rvmq-4x66-q7j3 lists affected ranges: PyPI apache-airflow >=0 <1.10.11rc1)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2020-11978 to the Known Exploited Vulnerabilities catalog on 2022-01-18.)

Commands are suggestions: review each one before running it.

Loading voting…