Skip to content

← Actionable
Critical, CVSS 9.8

Missing Authentication for Critical Function in Apache TomEE

CVE-2020-11969GHSA-836g-5fr5-fgcr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomee:tomee 8.0.2, 7.1.3, 7.0.8, 1.7.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.tomee:tomee

    Affected
    >= 8.0.0-M1, <= 8.0.1>= 7.1.0, <= 7.1.2>= 7.0.0-M1, <= 7.0.7>= 1.0.0, <= 1.7.5
    Fixed in
    7.0.8, 8.0.2, 7.1.3, 1.7.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-11969: 4.22% estimated exploitation activity in the next 30 days; percentile 91.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

If Apache TomEE is configured to use the embedded ActiveMQ broker, and the broker URI includes the useJMX=true parameter, a JMX port is opened on TCP port 1099, which does not include authentication. This affects Apache TomEE 8.0.0-M1 - 8.0.1, Apache TomEE 7.1.0 - 7.1.2, Apache TomEE 7.0.0-M1 - 7.0.7, Apache TomEE 1.0.0 - 1.7.5.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-836g-5fr5-fgcr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-11969

Advisory: Missing Authentication for Critical Function in Apache TomEE
IDs: CVE-2020-11969, GHSA-836g-5fr5-fgcr
Record: https://patchnext.com/advisories/cve-2020-11969 (revision 1, source checked 26 Oct 2026, 16:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomee:tomee 8.0.2, 7.1.3, 7.0.8, 1.7.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomee:tomee: affected >= 8.0.0-M1, <= 8.0.1; >= 7.1.0, <= 7.1.2; >= 7.0.0-M1, <= 7.0.7; >= 1.0.0, <= 1.7.5; fixed in 7.0.8, 8.0.2, 7.1.3, 1.7.6

## Suggested inspection (read-only)
- Maven org.apache.tomee:tomee: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomee:tomee.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-836g-5fr5-fgcr (GitHub-reviewed advisory GHSA-836g-5fr5-fgcr lists affected ranges: Maven org.apache.tomee:tomee >=8.0.0-M1 =7.1.0 =7.0.0-M1 =1.0.0 <=1.7.5)

Commands are suggestions: review each one before running it.

Loading voting…