Diavante vue-storefront-api and storefront-api disclose stack trace
CVE-2020-11883GHSA-9wxj-37p8-49ff
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (storefront-api 1.0.0-rc3; vue-storefront-api 1.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm storefront-api
- Affected
- < 1.0.0-rc3
- Fixed in
- 1.0.0-rc3
- Affected
- < 1.12.0
- Fixed in
- 1.12.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9wxj-37p8-49ff lists affected ranges: npm storefront-api >=0 =0 <1.12.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9wxj-37p8-49ff lists affected ranges: npm storefront-api >=0 =0 <1.12.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2020-11883: 15.15% estimated exploitation activity in the next 30 days; percentile 96.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Divante vue-storefront-api through 1.11.1 and storefront-api through 1.0-rc.1, as used in VueStorefront PWA, unexpected HTTP requests lead to an exception that discloses the error stack trace, with absolute file paths and Node.js module names.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9wxj-37p8-49ff
- Revision 1 · created ·
Published from osv record GHSA-9wxj-37p8-49ff
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-11883 Advisory: Diavante vue-storefront-api and storefront-api disclose stack trace IDs: CVE-2020-11883, GHSA-9wxj-37p8-49ff Record: https://patchnext.com/advisories/cve-2020-11883 (revision 2, source checked 26 Oct 2026, 12:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: storefront-api 1.0.0-rc3; vue-storefront-api 1.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm storefront-api: affected < 1.0.0-rc3; fixed in 1.0.0-rc3 - npm vue-storefront-api: affected < 1.12.0; fixed in 1.12.0 ## Suggested inspection (read-only) - `npm ls storefront-api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls vue-storefront-api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on storefront-api, vue-storefront-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9wxj-37p8-49ff (OSV record GHSA-9wxj-37p8-49ff lists affected ranges: npm storefront-api >=0 =0 <1.12.0 (fixed)) - Verified: https://github.com/advisories/GHSA-9wxj-37p8-49ff (GitHub-reviewed advisory GHSA-9wxj-37p8-49ff lists affected ranges: npm storefront-api >=0 =0 <1.12.0) Commands are suggestions: review each one before running it.
Loading voting…