Skip to content

← Actionable
High, CVSS 8.7amended

Hyperledger Indy's update process of a DID does not check who signs the request

CVE-2020-11093GHSA-wh2w-39f4-rpv2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (indy-node 1.12.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-11093: 1.18% estimated exploitation activity in the next 30 days; percentile 67.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Name Updating a DID with a nym transaction will be written to the ledger if neither ROLE or VERKEY are being changed, regardless of sender. Description A malicious DID with no particular role can ask an update for another DID (but cannot modify its verkey or role). This is bad because: 1. Any DID can write a nym transaction to the ledger (i.e., any DID can spam the ledger with nym transactions). 1. Any DID can change any other DID's alias. 1. The update transaction modifies the ledger metadata associated with a DID. Expected vs Observed We expect that if a DID (with no role) wants to update another DID (not its own or one it is the endorser), then the nodes should refuse the request. We can see that requirements in the Indy default authrules in Section "Who is the owner" in the last point of "Endorser using". We observe that with a normal DID, we can update the field from for a random DID, for example, the one of a TRUSTEE. It creates then a new transaction on the ledger. Explanation…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-wh2w-39f4-rpv2

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-wh2w-39f4-rpv2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-11093

Advisory: Hyperledger Indy's update process of a DID does not check who signs the request
IDs: CVE-2020-11093, GHSA-wh2w-39f4-rpv2
Record: https://patchnext.com/advisories/cve-2020-11093 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: indy-node 1.12.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI indy-node: affected < 1.12.4; fixed in 1.12.4

## Suggested inspection (read-only)
- `python -m pip show indy-node`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on indy-node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wh2w-39f4-rpv2 (OSV record GHSA-wh2w-39f4-rpv2 lists affected ranges: PyPI indy-node >=0 <1.12.4 (fixed))
- Verified: https://github.com/advisories/GHSA-wh2w-39f4-rpv2 (GitHub-reviewed advisory GHSA-wh2w-39f4-rpv2 lists affected ranges: PyPI indy-node >=0 <1.12.4)

Commands are suggestions: review each one before running it.

Loading voting…