Skip to content

← Actionable
High, CVSS 7.5

.NET Core & .NET Framework Denial of Service Vulnerability

CVE-2020-1108GHSA-3w5p-jhp5-c29q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (microsoft.netcore.app.runtime.win-x86 3.1.4; microsoft.netcore.app.runtime.win-arm64 3.1.4; microsoft.netcore.app.runtime.linux-musl-x64 3.1.4; microsoft.netcore.app.runtime.linux-arm64 3.1.4; microsoft.netcore.app.runtime.linux-arm 3.1.4; 7 more packages under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-3w5p-jhp5-c29q lists affected ranges: NuGet microsoft.netcore.app >=2.1.0 =3.1.0 =3.1.0 =3.1.0 =3.1.0 =3.1.0 =3.1.0 <3.1.4;…

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2020-1108: 6.46% estimated exploitation activity in the next 30 days; percentile 93.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A denial of service vulnerability exists when .NET Core or .NET Framework improperly handles web requests, aka '.NET Core & .NET Framework Denial of Service Vulnerability'.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3w5p-jhp5-c29q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-1108

Advisory: .NET Core & .NET Framework Denial of Service Vulnerability
IDs: CVE-2020-1108, GHSA-3w5p-jhp5-c29q
Record: https://patchnext.com/advisories/cve-2020-1108 (revision 1, source checked 26 Oct 2026, 16:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: microsoft.netcore.app.runtime.win-x86 3.1.4; microsoft.netcore.app.runtime.win-arm64 3.1.4; microsoft.netcore.app.runtime.linux-musl-x64 3.1.4; microsoft.netcore.app.runtime.linux-arm64 3.1.4; microsoft.netcore.app.runtime.linux-arm 3.1.4; microsoft.netcore.app.runtime.osx-x64 3.1.4; microsoft.netcore.app.runtime.linux-x64 3.1.4; microsoft.netcore.app 2.1.18; microsoft.netcore.app.runtime.win-arm 3.1.4; microsoft.netcore.app.runtime.rhel.6-x64 3.1.4; microsoft.netcore.app.runtime.linux-musl-arm64 3.1.4; microsoft.netcore.app.runtime.win-x64 3.1.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet microsoft.netcore.app.runtime.win-x86: affected >= 3.1.0, < 3.1.4; fixed in 3.1.4
- NuGet microsoft.netcore.app.runtime.win-arm64: affected >= 3.1.0, < 3.1.4; fixed in 3.1.4
- NuGet microsoft.netcore.app.runtime.linux-musl-x64: affected >= 3.1.0, < 3.1.4; fixed in 3.1.4
- NuGet microsoft.netcore.app.runtime.linux-arm64: affected >= 3.1.0, < 3.1.4; fixed in 3.1.4
- NuGet microsoft.netcore.app.runtime.linux-arm: affected >= 3.1.0, < 3.1.4; fixed in 3.1.4
- NuGet microsoft.netcore.app.runtime.osx-x64: affected >= 3.1.0, < 3.1.4; fixed in 3.1.4
- NuGet microsoft.netcore.app.runtime.linux-x64: affected >= 3.1.0, < 3.1.4; fixed in 3.1.4
- NuGet microsoft.netcore.app: affected >= 2.1.0, < 2.1.18; fixed in 2.1.18
- NuGet microsoft.netcore.app.runtime.win-arm: affected >= 3.1.0, < 3.1.4; fixed in 3.1.4
- NuGet microsoft.netcore.app.runtime.rhel.6-x64: affected >= 3.1.0, < 3.1.4; fixed in 3.1.4
- NuGet microsoft.netcore.app.runtime.linux-musl-arm64: affected >= 3.1.0, < 3.1.4; fixed in 3.1.4
- NuGet microsoft.netcore.app.runtime.win-x64: affected >= 3.1.0, < 3.1.4; fixed in 3.1.4

## Suggested inspection (read-only)
- NuGet microsoft.netcore.app.runtime.win-x86: check the installed version with your package manager.
- NuGet microsoft.netcore.app.runtime.win-arm64: check the installed version with your package manager.
- NuGet microsoft.netcore.app.runtime.linux-musl-x64: check the installed version with your package manager.
- NuGet microsoft.netcore.app.runtime.linux-arm64: check the installed version with your package manager.
- NuGet microsoft.netcore.app.runtime.linux-arm: check the installed version with your package manager.
- NuGet microsoft.netcore.app.runtime.osx-x64: check the installed version with your package manager.
- NuGet microsoft.netcore.app.runtime.linux-x64: check the installed version with your package manager.
- NuGet microsoft.netcore.app: check the installed version with your package manager.
- NuGet microsoft.netcore.app.runtime.win-arm: check the installed version with your package manager.
- NuGet microsoft.netcore.app.runtime.rhel.6-x64: check the installed version with your package manager.
- NuGet microsoft.netcore.app.runtime.linux-musl-arm64: check the installed version with your package manager.
- NuGet microsoft.netcore.app.runtime.win-x64: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on microsoft.netcore.app.runtime.win-x86, microsoft.netcore.app.runtime.win-arm64, microsoft.netcore.app.runtime.linux-musl-x64, microsoft.netcore.app.runtime.linux-arm64, microsoft.netcore.app.runtime.linux-arm, microsoft.netcore.app.runtime.osx-x64, microsoft.netcore.app.runtime.linux-x64, microsoft.netcore.app, microsoft.netcore.app.runtime.win-arm, microsoft.netcore.app.runtime.rhel.6-x64, microsoft.netcore.app.runtime.linux-musl-arm64, microsoft.netcore.app.runtime.win-x64.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3w5p-jhp5-c29q (GitHub-reviewed advisory GHSA-3w5p-jhp5-c29q lists affected ranges: NuGet microsoft.netcore.app >=2.1.0 =3.1.0 =3.1.0 =3.1.0 =3.1.0 =3.1.0 =3.1.0 <3.1.4;…)

Commands are suggestions: review each one before running it.

Loading voting…