False-negative validation results in MINT transactions with invalid baton
CVE-2020-11071GHSA-jc83-cpf9-q7c6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (slpjs 0.27.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm slpjs
- Affected
- < 0.27.2
- Fixed in
- 0.27.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jc83-cpf9-q7c6 lists affected ranges: npm slpjs >=0 <0.27.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jc83-cpf9-q7c6 lists affected ranges: npm slpjs >=0 <0.27.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
- EPSS
- CVE-2020-11071: 0.93% estimated exploitation activity in the next 30 days; percentile 60.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Users could experience false-negative validation outcomes for MINT transaction operations. A poorly implemented SLP wallet could allow spending of the affected tokens which would result in the destruction of a user's minting baton. Patches npm package slpjs has been patched and published as version 0.27.2. Workarounds Upgrade to slpjs 0.27.2. References slpjs commit For more information If you have any questions or comments about this advisory: Open an issue in slp-validate or slpjs
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jc83-cpf9-q7c6
- Revision 1 · created ·
Published from osv record GHSA-jc83-cpf9-q7c6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-11071 Advisory: False-negative validation results in MINT transactions with invalid baton IDs: CVE-2020-11071, GHSA-jc83-cpf9-q7c6 Record: https://patchnext.com/advisories/cve-2020-11071 (revision 2, source checked 26 Oct 2026, 12:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: slpjs 0.27.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm slpjs: affected < 0.27.2; fixed in 0.27.2 ## Suggested inspection (read-only) - `npm ls slpjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on slpjs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jc83-cpf9-q7c6 (OSV record GHSA-jc83-cpf9-q7c6 lists affected ranges: npm slpjs >=0 <0.27.2 (fixed)) - Verified: https://github.com/advisories/GHSA-jc83-cpf9-q7c6 (GitHub-reviewed advisory GHSA-jc83-cpf9-q7c6 lists affected ranges: npm slpjs >=0 <0.27.2) Commands are suggestions: review each one before running it.
Loading voting…