Cross-Site Scripting in TYPO3 CMS Link Handling
CVE-2020-11065GHSA-4j77-gg36-9864
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-core 10.4.2, 9.5.17; typo3/cms 10.4.2, 9.5.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist typo3/cms-core
- Affected
- >= 10.0.0, < 10.4.2>= 9.0.0, < 9.5.17
- Fixed in
- 9.5.17, 10.4.2
Packagist typo3/cms
- Affected
- >= 10.0.0, < 10.4.2>= 9.0.0, < 9.5.17
- Fixed in
- 9.5.17, 10.4.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4j77-gg36-9864 lists affected ranges: Packagist typo3/cms-core >=10.0.0 =9.0.0 =10.0.0 =9.0.0 <9.5.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2020-11065: 0.54% estimated exploitation activity in the next 30 days; percentile 45.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
It has been discovered that link tags generated by typolink functionality are vulnerable to cross-site scripting - properties being assigned as HTML attributes have not been parsed correctly. Update to TYPO3 versions 9.5.17 or 10.4.2 that fix the problem described. References https://typo3.org/security/advisory/typo3-core-sa-2020-003
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4j77-gg36-9864
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-11065 Advisory: Cross-Site Scripting in TYPO3 CMS Link Handling IDs: CVE-2020-11065, GHSA-4j77-gg36-9864 Record: https://patchnext.com/advisories/cve-2020-11065 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: typo3/cms-core 10.4.2, 9.5.17; typo3/cms 10.4.2, 9.5.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist typo3/cms-core: affected >= 10.0.0, < 10.4.2; >= 9.0.0, < 9.5.17; fixed in 9.5.17, 10.4.2 - Packagist typo3/cms: affected >= 10.0.0, < 10.4.2; >= 9.0.0, < 9.5.17; fixed in 9.5.17, 10.4.2 ## Suggested inspection (read-only) - Packagist typo3/cms-core: check the installed version with your package manager. - Packagist typo3/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on typo3/cms-core, typo3/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4j77-gg36-9864 (GitHub-reviewed advisory GHSA-4j77-gg36-9864 lists affected ranges: Packagist typo3/cms-core >=10.0.0 =9.0.0 =10.0.0 =9.0.0 <9.5.17) Commands are suggestions: review each one before running it.
Loading voting…