Skip to content

← Actionable
Critical, CVSS 9.6amended

Exposure of Sensitive Information to an Unauthorized Actor in AEgir

CVE-2020-11059GHSA-qfcv-5whw-7pcw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aegir 21.10.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm aegir

    Affected
    >= 21.7.0, < 21.10.1
    Fixed in
    21.10.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2020-11059: 1.12% estimated exploitation activity in the next 30 days; percentile 66.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact aegir publish and aegir build may leak secrets from environmental variables in the browser bundle published to npm. Patches The code has been patched, users should upgrade to = 21.10.1 Workarounds Run printenv to check your environment variables and revoke any secrets. For more information If you have any questions or comments about this advisory: Open an issue in aegir

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qfcv-5whw-7pcw

  2. Revision 1 · created ·

    Published from osv record GHSA-qfcv-5whw-7pcw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-11059

Advisory: Exposure of Sensitive Information to an Unauthorized Actor in AEgir
IDs: CVE-2020-11059, GHSA-qfcv-5whw-7pcw
Record: https://patchnext.com/advisories/cve-2020-11059 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aegir 21.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm aegir: affected >= 21.7.0, < 21.10.1; fixed in 21.10.1

## Suggested inspection (read-only)
- `npm ls aegir --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aegir.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qfcv-5whw-7pcw (OSV record GHSA-qfcv-5whw-7pcw lists affected ranges: npm aegir >=21.7.0 <21.10.1 (fixed))
- Verified: https://github.com/advisories/GHSA-qfcv-5whw-7pcw (GitHub-reviewed advisory GHSA-qfcv-5whw-7pcw lists affected ranges: npm aegir >=21.7.0 <21.10.1)

Commands are suggestions: review each one before running it.

Loading voting…