Skip to content

← Actionable
High, CVSS 7.4

Potential Code Injection in Sprout Forms

CVE-2020-11056GHSA-px8v-hxxx-2rgh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (barrelstrength/sprout-base-email 1.2.7; barrelstrength/sprout-forms 3.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
EPSS
  • CVE-2020-11056: 1.03% estimated exploitation activity in the next 30 days; percentile 63.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A potential Server-Side Template Injection vulnerability exists in Sprout Forms which could lead to the execution of Twig code. Patches The problem is fixed inbarrelstrength/sprout-forms:v3.9.0 which upgrades to barrelstrength/sprout-base-email:v1.2.7 Workarounds Users unable to upgrade should update any Notification Emails to use the "Basic Notification (Sprout Email)" template and avoid using the "Basic Notification (Sprout Forms)" template or any custom templates that display Form Fields. References - See the release notes in the CHANGELOG - Credits to Paweł Hałdrzyński, Daniel Kalinowski from ISEC.PL for discovery and responsible disclosure For more information If you have any questions or comments about this advisory: Open an issue in the Sprout Forms repo Email us at sprout@barrelstrengthdesign.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-px8v-hxxx-2rgh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-11056

Advisory: Potential Code Injection in Sprout Forms
IDs: CVE-2020-11056, GHSA-px8v-hxxx-2rgh
Record: https://patchnext.com/advisories/cve-2020-11056 (revision 1, source checked 26 Oct 2026, 14:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: barrelstrength/sprout-base-email 1.2.7; barrelstrength/sprout-forms 3.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist barrelstrength/sprout-base-email: affected < 1.2.7; fixed in 1.2.7
- Packagist barrelstrength/sprout-forms: affected < 3.9.0; fixed in 3.9.0

## Suggested inspection (read-only)
- Packagist barrelstrength/sprout-base-email: check the installed version with your package manager.
- Packagist barrelstrength/sprout-forms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on barrelstrength/sprout-base-email, barrelstrength/sprout-forms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-px8v-hxxx-2rgh (GitHub-reviewed advisory GHSA-px8v-hxxx-2rgh lists affected ranges: Packagist barrelstrength/sprout-base-email >=0 =0 <3.9.0)

Commands are suggestions: review each one before running it.

Loading voting…