Skip to content

← Actionable
Medium, CVSS 6.3

Cross-Site Scripting in BookStack

CVE-2020-11055GHSA-5vf7-q87h-pg6w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ssddanbrown/bookstack 0.29.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2020-11055: 0.78% estimated exploitation activity in the next 30 days; percentile 56.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A user with permission to create comments could POST HTML directly to the system to be saved in a comment, which would then be executed/displayed to others users viewing the comment. Through this vulnerability custom JavaScript code could be injected and therefore ran on other user machines. This most impacts scenarios where not-trusted users are given permission to create comments. Patches The issue was addressed in BookStack v0.29.2. After upgrading, The command php artisan bookstack:regenerate-comment-content should be ran to remove any pre-existing dangerous content. Workarounds Comments can be disabled in the system settings to prevent them being shown to users. Alternatively, comment creation permissions can be altered as required to only those who are trusted but this will not address existing exploitation of this vulnerability. References BookStack Beta v0.29.2 JVN#41035278 BookStack Blog Post For more information If you have any questions or comments about this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5vf7-q87h-pg6w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-11055

Advisory: Cross-Site Scripting in BookStack
IDs: CVE-2020-11055, GHSA-5vf7-q87h-pg6w
Record: https://patchnext.com/advisories/cve-2020-11055 (revision 1, source checked 26 Oct 2026, 13:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ssddanbrown/bookstack 0.29.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist ssddanbrown/bookstack: affected >= 0.18.0, < 0.29.2; fixed in 0.29.2

## Suggested inspection (read-only)
- Packagist ssddanbrown/bookstack: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ssddanbrown/bookstack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5vf7-q87h-pg6w (GitHub-reviewed advisory GHSA-5vf7-q87h-pg6w lists affected ranges: Packagist ssddanbrown/bookstack >=0.18.0 <0.29.2)

Commands are suggestions: review each one before running it.

Loading voting…