Skip to content

← Actionable
Low, CVSS 3.5amended

Incorrect Provision of Specified Functionality in qutebrowser

CVE-2020-11054GHSA-4rcq-jv2f-898j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (qutebrowser 1.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
EPSS
  • CVE-2020-11054: 1.51% estimated exploitation activity in the next 30 days; percentile 74.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description After a certificate error was overridden by the user, qutebrowser displays the URL as yellow (colors.statusbar.url.warn.fg). However, when the affected website was subsequently loaded again, the URL was mistakenly displayed as green (colors.statusbar.url.successhttps). While the user already has seen a certificate error prompt at this point (or set content.sslstrict to false which is not recommended), this could still provide a false sense of security. Affected versions and patches All versions of qutebrowser are believed to be affected, though versions before v0.11.x couldn't be tested. The issue is fixed in qutebrowser v1.11.1 (pending release) and v1.12.0 (unreleased). Backported patches for older versions are available, but no further releases are planned. Mitigation If you are unable to upgrade: - Treat any host with a certificate exception as insecure, ignoring the URL color - Or set content.sslstrict to True (instead of 'ask'), preventing certificate exceptions…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4rcq-jv2f-898j

  2. Revision 1 · created ·

    Published from osv record GHSA-4rcq-jv2f-898j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-11054

Advisory: Incorrect Provision of Specified Functionality in qutebrowser
IDs: CVE-2020-11054, GHSA-4rcq-jv2f-898j
Record: https://patchnext.com/advisories/cve-2020-11054 (revision 2, source checked 26 Oct 2026, 13:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: qutebrowser 1.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI qutebrowser: affected < 1.11.1; fixed in 1.11.1

## Suggested inspection (read-only)
- `python -m pip show qutebrowser`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on qutebrowser.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4rcq-jv2f-898j (OSV record GHSA-4rcq-jv2f-898j lists affected ranges: PyPI qutebrowser >=0 <1.11.1 (fixed))
- Verified: https://github.com/advisories/GHSA-4rcq-jv2f-898j (GitHub-reviewed advisory GHSA-4rcq-jv2f-898j lists affected ranges: PyPI qutebrowser >=0 <1.11.1)

Commands are suggestions: review each one before running it.

Loading voting…