Skip to content

← Actionable
High, CVSS 8.3

Improper Restriction of Excessive Authentication Attempts in Sorcery

CVE-2020-11052GHSA-jc8m-cxhj-668x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sorcery 0.15.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems sorcery

    Affected
    < 0.15.0
    Fixed in
    0.15.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L
EPSS
  • CVE-2020-11052: 1.60% estimated exploitation activity in the next 30 days; percentile 75.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout. Patches Patched as of version 0.15.0. Workarounds Currently no workarounds, other than monkey patching the authenticate method provided by Sorcery or upgrading to version 0.15.0.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jc8m-cxhj-668x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-11052

Advisory: Improper Restriction of Excessive Authentication Attempts in Sorcery
IDs: CVE-2020-11052, GHSA-jc8m-cxhj-668x
Record: https://patchnext.com/advisories/cve-2020-11052 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sorcery 0.15.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems sorcery: affected < 0.15.0; fixed in 0.15.0

## Suggested inspection (read-only)
- RubyGems sorcery: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sorcery.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jc8m-cxhj-668x (GitHub-reviewed advisory GHSA-jc8m-cxhj-668x lists affected ranges: RubyGems sorcery >=0 <0.15.0)

Commands are suggestions: review each one before running it.

Loading voting…