Skip to content

← Actionable
Medium, CVSS 4.3amended

Potential Observable Timing Discrepancy in Wagtail

CVE-2020-11037GHSA-jjjr-3jcw-f8v6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 2.9, 2.8.2, 2.7.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI wagtail

    Affected
    < 2.7.3>= 2.8rc1, < 2.8.2>= 2.9rc1, <= 2.9rc1
    Fixed in
    2.7.3, 2.9, 2.8.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N · score source
EPSS
  • CVE-2020-11037: 0.25% estimated exploitation activity in the next 30 days; percentile 16.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A potential timing attack exists on pages or documents that have been protected with a shared password through Wagtail's "Privacy" controls. This password check is performed through a character-by-character string comparison, and so an attacker who is able to measure the time taken by this check to a high degree of accuracy could potentially use timing differences to gain knowledge of the password. (This is understood to be feasible on a local network, but not on the public internet.) Privacy settings that restrict access to pages / documents on a per-user or per-group basis (as opposed to a shared password) are unaffected by this vulnerability. Patches Patched versions have been released as Wagtail 2.7.3 (for the LTS 2.7 branch), Wagtail 2.8.2 and Wagtail 2.9. Workarounds Site owners who are unable to upgrade to the new versions can use user- or group-based privacy restrictions to restrict access to sensitive information; these are unaffected by this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jjjr-3jcw-f8v6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-jjjr-3jcw-f8v6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-11037

Advisory: Potential Observable Timing Discrepancy in Wagtail
IDs: CVE-2020-11037, GHSA-jjjr-3jcw-f8v6
Record: https://patchnext.com/advisories/cve-2020-11037 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wagtail 2.9, 2.8.2, 2.7.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI wagtail: affected < 2.7.3; >= 2.8rc1, < 2.8.2; >= 2.9rc1, <= 2.9rc1; fixed in 2.7.3, 2.9, 2.8.2

## Suggested inspection (read-only)
- `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wagtail.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jjjr-3jcw-f8v6 (OSV record GHSA-jjjr-3jcw-f8v6 lists affected ranges: PyPI wagtail >=0 =2.8rc1 =2.9rc1 <2.9 (fixed))
- Verified: https://github.com/advisories/GHSA-jjjr-3jcw-f8v6 (GitHub-reviewed advisory GHSA-jjjr-3jcw-f8v6 lists affected ranges: PyPI wagtail >=0 =2.8rc1 =2.9rc1 <=2.9rc1)

Commands are suggestions: review each one before running it.

Loading voting…