Authentication and extension bypass in Faye
CVE-2020-11020GHSA-qpg4-4w7w-2mq5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (faye 1.2.5, 1.1.3, 1.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems faye
- Affected
- >= 0.5.0, < 1.0.4>= 1.1.0, < 1.1.3>= 1.2.0, < 1.2.5
- Fixed in
- 1.0.4, 1.2.5, 1.1.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qpg4-4w7w-2mq5 lists affected ranges: RubyGems faye >=0.5.0 =1.1.0 =1.2.0 <1.2.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2020-11020: 1.57% estimated exploitation activity in the next 30 days; percentile 75.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
On 20 April 2020 it was reported to me that the potential for authentication bypass exists in [Faye][1]'s extension system. This vulnerability has existed in the Node.js and Ruby versions of the server since version 0.5.0, when extensions were first introduced, in July 2010. It is patched in versions 1.0.4, 1.1.3 and 1.2.5, which we are releasing today. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. For example, the Faye [extension docs][2] suggest that users implement access control for subscriptions by checking incoming messages for the /meta/subscribe channel, for example: A bug in the server's code for recognising the special /meta/ channels, which trigger connection and subscription events, means that a client can bypass this check by sending a message to /meta/subscribe/x rather than /meta/subscribe: This message will not be checked by the above extension, as it checks the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qpg4-4w7w-2mq5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-11020 Advisory: Authentication and extension bypass in Faye IDs: CVE-2020-11020, GHSA-qpg4-4w7w-2mq5 Record: https://patchnext.com/advisories/cve-2020-11020 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: faye 1.2.5, 1.1.3, 1.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems faye: affected >= 0.5.0, < 1.0.4; >= 1.1.0, < 1.1.3; >= 1.2.0, < 1.2.5; fixed in 1.0.4, 1.2.5, 1.1.3 ## Suggested inspection (read-only) - RubyGems faye: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on faye. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qpg4-4w7w-2mq5 (GitHub-reviewed advisory GHSA-qpg4-4w7w-2mq5 lists affected ranges: RubyGems faye >=0.5.0 =1.1.0 =1.2.0 <1.2.5) Commands are suggestions: review each one before running it.
Loading voting…