SQL injection in Tortoise ORM
CVE-2020-11010GHSA-9j2c-x8qm-qmjq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tortoise-orm 0.16.6, 0.15.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tortoise-orm
- Affected
- < 0.15.23>= 0.16.0, < 0.16.6
- Fixed in
- 0.16.6, 0.15.23
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9j2c-x8qm-qmjq lists affected ranges: PyPI tortoise-orm >=0 =0.16.0 <0.16.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9j2c-x8qm-qmjq lists affected ranges: PyPI tortoise-orm >=0 =0.16.0 <0.16.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2020-11010: 1.05% estimated exploitation activity in the next 30 days; percentile 64.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Various forms of SQL injection has been found, for MySQL and when filtering or doing mass-updates on char/text fields. SQLite & PostgreSQL was only affected when filtering with contains, startswith or endswith filters (and their case-insensitive counterparts) Patches Please upgrade to 0.15.23+ or 0.16.6+ For more information If you have any questions or comments about this advisory: Open an issue in Github Chat to us on Gitter
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9j2c-x8qm-qmjq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9j2c-x8qm-qmjq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-11010 Advisory: SQL injection in Tortoise ORM IDs: CVE-2020-11010, GHSA-9j2c-x8qm-qmjq Record: https://patchnext.com/advisories/cve-2020-11010 (revision 3, source checked 26 Oct 2026, 13:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tortoise-orm 0.16.6, 0.15.23. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tortoise-orm: affected < 0.15.23; >= 0.16.0, < 0.16.6; fixed in 0.16.6, 0.15.23 ## Suggested inspection (read-only) - `python -m pip show tortoise-orm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tortoise-orm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9j2c-x8qm-qmjq (OSV record GHSA-9j2c-x8qm-qmjq lists affected ranges: PyPI tortoise-orm >=0 =0.16.0 <0.16.6 (fixed)) - Verified: https://github.com/advisories/GHSA-9j2c-x8qm-qmjq (GitHub-reviewed advisory GHSA-9j2c-x8qm-qmjq lists affected ranges: PyPI tortoise-orm >=0 =0.16.0 <0.16.6) Commands are suggestions: review each one before running it.
Loading voting…