Skip to content

← Actionable
Medium, CVSS 4.6amended

Possible XSS attack in Wagtail

CVE-2020-11001GHSA-v2wc-pfq2-5cm6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 2.8.1, 2.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI wagtail

    Affected
    >= 1.9.0, < 2.7.2>= 2.8.0, <= 2.8.0
    Fixed in
    2.8.1, 2.7.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2020-11001: 1.27% estimated exploitation activity in the next 30 days; percentile 69.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A cross-site scripting (XSS) vulnerability exists on the page revision comparison view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft a page revision history that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patches Patched versions have been released as Wagtail 2.7.2 (for the LTS 2.7 branch) and Wagtail 2.8.1 (for the current 2.8 branch). Workarounds Site owners who are unable to upgrade to the new versions can disable the revision comparison view by adding the following URL route to the top of their project's urls.py configuration: from django.views.generic.base import RedirectView urlpatterns = [ url(r'^admin/pages/(\d+)/revisions/compare/', RedirectView.asview(url='/admin/')),

... ] Acknowledgements Many thanks to Vlad Gerasimenko for…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v2wc-pfq2-5cm6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-v2wc-pfq2-5cm6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-11001

Advisory: Possible XSS attack in Wagtail
IDs: CVE-2020-11001, GHSA-v2wc-pfq2-5cm6
Record: https://patchnext.com/advisories/cve-2020-11001 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wagtail 2.8.1, 2.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI wagtail: affected >= 1.9.0, < 2.7.2; >= 2.8.0, <= 2.8.0; fixed in 2.8.1, 2.7.2

## Suggested inspection (read-only)
- `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wagtail.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v2wc-pfq2-5cm6 (OSV record GHSA-v2wc-pfq2-5cm6 lists affected ranges: PyPI wagtail >=1.9.0 =2.8.0 <2.8.1 (fixed))
- Verified: https://github.com/advisories/GHSA-v2wc-pfq2-5cm6 (GitHub-reviewed advisory GHSA-v2wc-pfq2-5cm6 lists affected ranges: PyPI wagtail >=1.9.0 =2.8.0 <=2.8.0)

Commands are suggestions: review each one before running it.

Loading voting…