Skip to content

← Actionable
High, CVSS 8.0

phpMyAdmin SQL Injection

CVE-2020-10804GHSA-h65r-8fp8-w7cx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyadmin/phpmyadmin 5.0.2, 4.9.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-10804: 2.35% estimated exploitation activity in the next 30 days; percentile 83.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was found in retrieval of the current username (in libraries/classes/Server/Privileges.php and libraries/classes/UserPassword.php). A malicious user with access to the server could create a crafted username, and then trick the victim into performing specific actions with that user account (such as editing its privileges).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h65r-8fp8-w7cx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-10804

Advisory: phpMyAdmin SQL Injection
IDs: CVE-2020-10804, GHSA-h65r-8fp8-w7cx
Record: https://patchnext.com/advisories/cve-2020-10804 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpmyadmin/phpmyadmin 5.0.2, 4.9.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpmyadmin/phpmyadmin: affected >= 4.9.0, < 4.9.5; >= 5.0.0, < 5.0.2; fixed in 4.9.5, 5.0.2

## Suggested inspection (read-only)
- Packagist phpmyadmin/phpmyadmin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpmyadmin/phpmyadmin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h65r-8fp8-w7cx (GitHub-reviewed advisory GHSA-h65r-8fp8-w7cx lists affected ranges: Packagist phpmyadmin/phpmyadmin >=4.9.0 =5.0.0 <5.0.2)

Commands are suggestions: review each one before running it.

Loading voting…