phpMyAdmin SQL injection vulnerability
CVE-2020-10802GHSA-f4cr-3xmc-2wpm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyadmin/phpmyadmin 5.0.2, 4.9.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmyadmin/phpmyadmin
- Affected
- >= 4.9.0, < 4.9.5>= 5.0.0, < 5.0.2
- Fixed in
- 4.9.5, 5.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f4cr-3xmc-2wpm lists affected ranges: Packagist phpmyadmin/phpmyadmin >=4.9.0 =5.0.0 <5.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-10802: 1.82% estimated exploitation activity in the next 30 days; percentile 78.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability has been discovered where certain parameters are not properly escaped when generating certain queries for search actions in libraries/classes/Controllers/Table/TableSearchController.php. An attacker can generate a crafted database or table name. The attack can be performed if a user attempts certain search operations on the malicious database or table.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f4cr-3xmc-2wpm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-10802 Advisory: phpMyAdmin SQL injection vulnerability IDs: CVE-2020-10802, GHSA-f4cr-3xmc-2wpm Record: https://patchnext.com/advisories/cve-2020-10802 (revision 1, source checked 26 Oct 2026, 14:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmyadmin/phpmyadmin 5.0.2, 4.9.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmyadmin/phpmyadmin: affected >= 4.9.0, < 4.9.5; >= 5.0.0, < 5.0.2; fixed in 4.9.5, 5.0.2 ## Suggested inspection (read-only) - Packagist phpmyadmin/phpmyadmin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmyadmin/phpmyadmin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f4cr-3xmc-2wpm (GitHub-reviewed advisory GHSA-f4cr-3xmc-2wpm lists affected ranges: Packagist phpmyadmin/phpmyadmin >=4.9.0 =5.0.0 <5.0.2) Commands are suggestions: review each one before running it.
Loading voting…