Skip to content

← Actionable
Critical, CVSS 9.8

dom4j allows External Entities by default which might enable XXE attacks

CVE-2020-10683GHSA-hwj3-m3p6-hj38

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven dom4j:dom4j

    Affected
    <= 1.6.1
    Fixed in
    no fixed version recorded
  • Maven org.dom4j:dom4j

    Affected
    < 2.0.3>= 2.1.0, < 2.1.3
    Fixed in
    2.0.3, 2.1.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-10683: 7.27% estimated exploitation activity in the next 30 days; percentile 94.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

dom4j before 2.1.3 allows external DTDs and External Entities by default, which might enable XXE attacks. However, there is popular external documentation from OWASP showing how to enable the safe, non-default behavior in any application that uses dom4j. Note: This advisory applies to dom4j:dom4j version 1.x legacy artifacts. To resolve this a change to the latest version of org.dom4j:dom4j is recommended.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hwj3-m3p6-hj38

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-10683

Advisory: dom4j allows External Entities by default which might enable XXE attacks
IDs: CVE-2020-10683, GHSA-hwj3-m3p6-hj38
Record: https://patchnext.com/advisories/cve-2020-10683 (revision 1, source checked 26 Oct 2026, 16:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.dom4j:dom4j 2.1.3, 2.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven dom4j:dom4j: affected <= 1.6.1
- Maven org.dom4j:dom4j: affected < 2.0.3; >= 2.1.0, < 2.1.3; fixed in 2.0.3, 2.1.3

## Suggested inspection (read-only)
- Maven dom4j:dom4j: check the installed version with your package manager.
- Maven org.dom4j:dom4j: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dom4j:dom4j, org.dom4j:dom4j.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hwj3-m3p6-hj38 (GitHub-reviewed advisory GHSA-hwj3-m3p6-hj38 lists affected ranges: Maven org.dom4j:dom4j >=0 =2.1.0 =0 <=1.6.1)

Commands are suggestions: review each one before running it.

Loading voting…