HashiCorp Vault Improper Privilege Management
CVE-2020-10660GHSA-m979-w9wj-qfj9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/vault 1.3.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.9.0, < 1.3.4
- Fixed in
- 1.3.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m979-w9wj-qfj9 lists affected ranges: Go github.com/hashicorp/vault >=0.9.0 <1.3.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2020-10660: 0.76% estimated exploitation activity in the next 30 days; percentile 55.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
HashiCorp Vault and Vault Enterprise versions 0.9.0 through 1.3.3 may, under certain circumstances, have an Entity's Group membership inadvertently include Groups the Entity no longer has permissions to. Fixed in 1.3.4.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m979-w9wj-qfj9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-10660 Advisory: HashiCorp Vault Improper Privilege Management IDs: CVE-2020-10660, GHSA-m979-w9wj-qfj9 Record: https://patchnext.com/advisories/cve-2020-10660 (revision 1, source checked 26 Oct 2026, 15:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/vault 1.3.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hashicorp/vault: affected >= 0.9.0, < 1.3.4; fixed in 1.3.4 ## Suggested inspection (read-only) - Go github.com/hashicorp/vault: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hashicorp/vault. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m979-w9wj-qfj9 (GitHub-reviewed advisory GHSA-m979-w9wj-qfj9 lists affected ranges: Go github.com/hashicorp/vault >=0.9.0 <1.3.4) Commands are suggestions: review each one before running it.
Loading voting…