Skip to content

← Actionable
Critical, CVSS 9.3amended

Potential buffer overflow in psd-tools

CVE-2020-10571GHSA-22jr-vc7j-g762

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (psd-tools 1.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI psd-tools

    Affected
    >= 1.8.37, <= 1.9.3
    Fixed in
    1.9.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-10571: 1.80% estimated exploitation activity in the next 30 days; percentile 78.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An issue was discovered in psd-tools before 1.9.4. The Cython implementation of RLE decoding did not check for malformed PSD input data during decoding to the PIL.Image or NumPy format, leading to a Buffer Overflow. Patches Users of psd-tools version v1.8.37 to v1.9.3 should upgrade to v1.9.4. Workarounds Without Cython present on installation, buffer overflow does not occur but IndexError will be thrown. However, already installed psd-tools with Cython extention should be upgraded. References https://github.com/psd-tools/psd-tools/pull/198 For more information If you have any questions or comments about this advisory: Open an issue in psd-tools

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-22jr-vc7j-g762

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-22jr-vc7j-g762

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-10571

Advisory: Potential buffer overflow in psd-tools
IDs: CVE-2020-10571, GHSA-22jr-vc7j-g762
Record: https://patchnext.com/advisories/cve-2020-10571 (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: psd-tools 1.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI psd-tools: affected >= 1.8.37, <= 1.9.3; fixed in 1.9.4

## Suggested inspection (read-only)
- `python -m pip show psd-tools`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on psd-tools.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-22jr-vc7j-g762 (OSV record GHSA-22jr-vc7j-g762 lists affected ranges: PyPI psd-tools >=1.8.37 <1.9.4 (fixed))
- Verified: https://github.com/advisories/GHSA-22jr-vc7j-g762 (GitHub-reviewed advisory GHSA-22jr-vc7j-g762 lists affected ranges: PyPI psd-tools >=1.8.37 <=1.9.3)

Commands are suggestions: review each one before running it.

Loading voting…