Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper
CVE-2020-10187GHSA-j7vx-8mqj-cqp9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (doorkeeper 5.3.2, 5.2.5, 5.1.1, 5.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems doorkeeper
- Affected
- >= 5.0.0, < 5.0.3>= 5.1.0, <= 5.1.0>= 5.2.0, < 5.2.5>= 5.3.0, < 5.3.2
- Fixed in
- 5.2.5, 5.3.2, 5.0.3, 5.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j7vx-8mqj-cqp9 lists affected ranges: RubyGems doorkeeper >=5.0.0 =5.1.0 =5.2.0 =5.3.0 <5.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2020-10187: 1.78% estimated exploitation activity in the next 30 days; percentile 78.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Information disclosure vulnerability. Allows an attacker to see all Doorkeeper::Application model attribute values (including secrets) using authorized applications controller if it's enabled (GET /oauth/authorizedapplications.json). Patches These versions have the fix: 5.0.3 5.1.1 5.2.5 5.3.2 Workarounds Patch Doorkeeper::Application model #asjson(options = {}) method and define only those attributes you want to expose. Additional recommended hardening is to enable application secrets hashing (guide), available since Doorkeeper 5.1. This would render the exposed secret useless. References - Commit with fix: https://github.com/doorkeeper-gem/doorkeeper/commit/25d038022c2fcad45af5b73f9d003cf38ff491f6 - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-10187
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j7vx-8mqj-cqp9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-10187 Advisory: Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper IDs: CVE-2020-10187, GHSA-j7vx-8mqj-cqp9 Record: https://patchnext.com/advisories/cve-2020-10187 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: doorkeeper 5.3.2, 5.2.5, 5.1.1, 5.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems doorkeeper: affected >= 5.0.0, < 5.0.3; >= 5.1.0, <= 5.1.0; >= 5.2.0, < 5.2.5; >= 5.3.0, < 5.3.2; fixed in 5.2.5, 5.3.2, 5.0.3, 5.1.1 ## Suggested inspection (read-only) - RubyGems doorkeeper: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on doorkeeper. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j7vx-8mqj-cqp9 (GitHub-reviewed advisory GHSA-j7vx-8mqj-cqp9 lists affected ranges: RubyGems doorkeeper >=5.0.0 =5.1.0 =5.2.0 =5.3.0 <5.3.2) Commands are suggestions: review each one before running it.
Loading voting…